Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18611 - [openssh] restart kills all sessions

Attached to Project: Arch Linux
Opened by Florian Pritz (bluewind) - Monday, 08 March 2010, 19:05 GMT
Last edited by Aaron Griffin (phrakture) - Friday, 19 March 2010, 18:08 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Aaron Griffin (phrakture)
Dan Griffiths (Ghost1227)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
/etc/rc.d/sshd restart
kills all open ssh sessions.

Source of problem:
http://repos.archlinux.org/wsvn/packages/openssh/trunk/?op=revision&rev=60182

Please revert the commit or ensure that you only kill the daemon and not the sessions (they also use /usr/sbin/sshd).
This task depends upon

Closed by  Aaron Griffin (phrakture)
Friday, 19 March 2010, 18:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  Changes in the package were reverted
Comment by Florian Pritz (bluewind) - Monday, 08 March 2010, 19:08 GMT
Oh forgot: it's due to version 5.3p1-4.
Comment by Knut Tidemann (Avenger) - Monday, 08 March 2010, 19:21 GMT
I can confirm this, and I can also add that opensshd did not start again on one of my computers, which I don't have physical access to, so I'm now locked out.

I would look for error messages of some sort, but I cannot access the system.

I did a restart today after the upgrade of openssl and openssh to openssh 5.3p1-4 and openssl 0.9.8m-2.
Comment by Bjørn Øivind Bjørnsen (MrKaKe) - Monday, 08 March 2010, 19:22 GMT
Same behaviour here, openssh 5.3p1-4.
Comment by Linas (Linas) - Wednesday, 10 March 2010, 12:53 GMT
It should read /var/run/sshd.pid as it did on previous version.
The -o %PPID parameter, which I guess wanted to avoid killing the current session, is completely useless.
Since it kills all ssh instances, a restart via ssh means that the restart script will be killed before the server is started again, locking the user out.
Comment by Damjan Georgievski (damjan) - Friday, 12 March 2010, 21:23 GMT
Why was it decided to not trust /var/run/sshd.pid in the first place?
Comment by Linas (Linas) - Thursday, 18 March 2010, 21:40 GMT
Because  FS#17138  (startup scripts should check pid files more closely).
This was fixed on latest package, so I think this bug can be closed.
Comment by Aaron Griffin (phrakture) - Thursday, 18 March 2010, 23:08 GMT
Florian, can you confirm that the revert in the package fixed this and the bug can be closed?
Comment by Florian Pritz (bluewind) - Friday, 19 March 2010, 12:46 GMT
Yes works fine now. Thanks

Loading...