Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18604 - [tomcat] 5.5.28-2 in i686 has wrong configuration

Attached to Project: Arch Linux
Opened by Jarosław Górny (jaroslav) - Monday, 08 March 2010, 10:07 GMT
Last edited by Paul Mattal (paul) - Wednesday, 10 March 2010, 23:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Paul Mattal (paul)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:tomcat version 5.5.28-2 for i686 systems contains 64bit software / configuration.
It's imposible to use it. After upgrade starting tomcat fails to start.
I have used 'strace' and indeed, tomcat tries to load libraries from */amd64/ dir, when they exist in */i386/ dir.


Steps to reproduce:
Upgrade tomcat to 5.5.28-2 on 32 bit system and stop/start tomcat server
This task depends upon

Closed by  Paul Mattal (paul)
Wednesday, 10 March 2010, 23:04 GMT
Reason for closing:  Fixed
Comment by Paul Mattal (paul) - Monday, 08 March 2010, 12:45 GMT
This may have been caused by a bug in my makepkg.conf for my i686 chroot.

Can you report if 5.5.28-3, just released, fixes it?
Comment by Jarosław Górny (jaroslav) - Monday, 08 March 2010, 17:44 GMT
no, it's not working with *-3 too.

08/03/2010 18:42:25 22786 jsvc error: Cannot find any VM in Java Home /usr/lib/jvm/java-6-openjdk
/etc/rc.d/tomcat: line 8: 22786 Naruszenie ochrony pamięci /opt/tomcat/bin/jsvc -user tomcat -home $TOMCAT_JAVA_HOME -Dcatalina.home=/opt/tomcat -Dcatalina.base=/opt/tomcat -Djava.io.tmpdir=/opt/tomcat/temp -wait 10 -pidfile /var/run/tomcat.pid -errfile /opt/tomcat/logs/catalina.log $CATALINA_OPTS -cp $TOMCAT_JAVA_HOME/lib/tools.jar:/opt/tomcat/bin/commons-daemon.jar:/opt/tomcat/bin/bootstrap.jar org.apache.catalina.startup.Bootstrap
Comment by Paul Mattal (paul) - Monday, 08 March 2010, 17:48 GMT
Which JVM do you have installed? If you've got openjdk6 installed, it should be able to find the VM in the path indicated above.

If you are using some other JVM (technically unsupported), you'll have to edit /etc/conf.d/tomcat to point TOMCAT_JAVA_HOME to the right place for that JVM.
Comment by Jarosław Górny (jaroslav) - Monday, 08 March 2010, 19:11 GMT
[root@masala tmp]# pacman -Qs jdk
local/openjdk6 6.b17_1.7.1-1
Free Java environment based on OpenJDK 6.0 with IcedTea6 replacing binary plugs.

And also note that with tomcat 5.5.28-1 (and previous) it was working correctly. If Your assumptions were correct, it wouldn't work for previous tomcat package too.
Comment by Paul Mattal (paul) - Tuesday, 09 March 2010, 04:42 GMT
This is apparently not buildable for i686 on an x86_64 in a chroot, for reasons we haven't yet sorted out.

I've built -4 on actual i686 (in a chroot). Let me know if this works!
Comment by Jarosław Górny (jaroslav) - Tuesday, 09 March 2010, 09:49 GMT
build *-4 works OK. I've restarted tomcat and it was successfull. Thanks!
J.

Loading...