Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18598 - [xorg-server] 1.7.5.901-1 (fluxbox issues)

Attached to Project: Arch Linux
Opened by harryNID (harryNID) - Sunday, 07 March 2010, 21:07 GMT
Last edited by Paul Mattal (paul) - Monday, 15 March 2010, 03:13 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
New version of Xorg-Server causes Fluxbox (and apparently pekwm) to lock-up hard.

More about this issue can be read here:
http://bbs.archlinux.org/viewtopic.php?id=92679

Additional info:
* package version(s)
xorg-server 1.7.5.901-1
fluxbox-git 20100307-1
fluxbox 1.1.1-1
pekwm 0.1.11-2 (unconfirmed)
No apparent events are logged.


Steps to reproduce:
Login press any button. All graphical elements lock up immediately. CTRL+ALT+F1 works to escape to a terminal.

Since the new version re-enabled --enable-record I tried recompiling disabling that option. No change!
This task depends upon

Closed by  Paul Mattal (paul)
Monday, 15 March 2010, 03:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed upstream in 1.7.5.902-2. If you still have trouble with this bug first time launching X after rebooting, try a full-power-plug reboot before reopening this bug!
Comment by Jan de Groot (JGC) - Sunday, 07 March 2010, 21:17 GMT
Please try to find the problem by using git bisection. This should uncover the problem quite easily and helps upstream to fix xorg-server before they release 1.7.6.
Comment by harryNID (harryNID) - Monday, 08 March 2010, 00:00 GMT
Jan, if your response was intended for me then I must profess ignorance when it comes to git. I am not a programmer by trade and I only have a rudimentary knowledge of git. I will of course help in other way that I can however.
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 08 March 2010, 01:00 GMT Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 08 March 2010, 01:28 GMT
anybody interesting in testing it and if no other issues are present... here is the PKGBUILD modified plus the patch

http://bugs.freedesktop.org/show_bug.cgi?id=25400

I don't know about this, maybe is a bug in fluxbox, or maybe something is wrong with this change. Open a ticket in http://bugs.freedesktop.org

Searching in ML, some time ago a guy reported the issue:
xorg-devel@lists.x.org/msg05737.html"> http://www.mail-archive.com/xorg-devel@lists.x.org/msg05737.html
Comment by tom f. (scrawler) - Monday, 08 March 2010, 03:36 GMT
I use icewm and this affects me too.
Comment by Marco Siviero (xavi) - Monday, 08 March 2010, 17:12 GMT
Same problem here with fluxbox-git.
Comment by Arthur Huillet (ahuillet) - Monday, 08 March 2010, 17:23 GMT
I am having the problem too. Gerardo's patch fixes it - I suggest adding it to the PKGBUILD until the X.org guys have fixed it.
Comment by Ben Tartsa (leadghost) - Monday, 08 March 2010, 18:56 GMT
Openbox freezing up as well.
Comment by harryNID (harryNID) - Monday, 08 March 2010, 21:09 GMT
I too tried Gerardo patch and the problem appears to be fixed by using it.
Comment by Jan de Groot (JGC) - Monday, 08 March 2010, 22:00 GMT
Fixed in 1.7.5.901-2. Please leave this bug open until upstream has a different solution.
Comment by Paul Mattal (paul) - Monday, 15 March 2010, 02:53 GMT
I did a full bisect on my system, too, and determined the same commit was to blame.

BUT: It appears I still get this bad behavior the very first time I launch X after rebooting each time, even with 1.7.5.901-2.

Can anyone else confirm this behavior, or is it just me?
Comment by Paul Mattal (paul) - Monday, 15 March 2010, 03:12 GMT
Wow. So after testing 1.7.5, 1.7.3, and 1.7.1 with the same behavior, I tried halting, pulling the plug, reapplying power, and rebooting.

It would appear something had been set in an odd default state in the hardware. I now work correctly on first boot.

I hate hardware bugs, but probably not as much as Jan, so I'll just close this bug now. I think it really is dead.

Loading...