Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#18568 - [makepkg] fails to compress man page links sometimes

Attached to Project: Pacman
Opened by Allan McRae (Allan) - Friday, 05 March 2010, 03:44 GMT
Last edited by Dan McGee (toofishes) - Monday, 15 March 2010, 00:19 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version 3.3.3
Due in Version 3.4.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
Sometimes makepkg fails to compress symlinks to man pages. This is demonstrated in Arch with the gvim, gimp and sox packages.

The only time I can replicate it is with having both hard and symbolic links to a file and the symlink coming alphabetically before the man page and and hardlinks.

It looks like this was introduced with this commit: http://projects.archlinux.org/pacman.git/commit/?id=9615d823 . We should never trust someone using a hotmail address! :D

Steps to Reproduce:
See attached PKGBUILD.
   PKGBUILD (0.2 KiB)
This task depends upon

Closed by  Dan McGee (toofishes)
Monday, 15 March 2010, 00:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  http://projects.archlinux.org/pacman.git /commit/?id=6f0ffb23860e8d1b4593d60e9709 19ae7b31340d
Comment by Allan McRae (Allan) - Friday, 05 March 2010, 04:04 GMT
Looking at the code, it occurs when a symlinks does not point to the alphabetically first of the hardlinked files
Comment by Allan McRae (Allan) - Saturday, 06 March 2010, 22:27 GMT

Loading...