Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18496 - [feh] fails when using rotate in place for jpeg images

Attached to Project: Arch Linux
Opened by Rodney Padgett (rp) - Sunday, 28 February 2010, 13:11 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 04 March 2010, 13:58 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
As of libjpeg-8, the lossless rotate function in feh stopped working, with error 'bogus array access'. I have fixed this problem & emailed the author, but got no reply, so I'll post it here instead since I use Arch!

Fix:

In root FEH directory,
1. remove jpegint.h from src/
2. copy latest transupp.h & transupp.c from libjpeg-8 sources to /src
3. Add extra initialisation (patch file attached) to /src/imlib.c function feh_edit_inplace_lossless_rotate():
transformoption.perfect = FALSE;
transformoption.crop = FALSE;

Rotate then works & I've had no further problems.

Additional info:
* package version - latest update, extra/feh 1.3.4-6

Steps to reproduce:
feh -F <any jpeg image>

then use shift - < > (or menu) to do in place rotate.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 04 March 2010, 13:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  feh 1.3.5.040310
Comment by Andrea Scarpino (BaSh) - Thursday, 04 March 2010, 13:32 GMT
I cannot reproduce it here.

EDIT: tried with another image and it crashed...

Loading...