Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18486 - [nvidia-utils] does not install OpenCL lib and include files

Attached to Project: Arch Linux
Opened by Stéphane Gaudreault (st_0xef) - Saturday, 27 February 2010, 15:51 GMT
Last edited by Pierre Schmitz (Pierre) - Wednesday, 23 June 2010, 10:49 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 17
Private No

Details

Description:

The new nvidia driver (NVIDIA-Linux-x86_64-195.36.08-pkg0.run) provide the OpenCL lib and include files bellow, but PKGBUILD does not install them. Would it be possible to install these files too please ?

NVIDIA-Linux-x86_64-195.36.08-pkg0/etc/OpenCL
NVIDIA-Linux-x86_64-195.36.08-pkg0/etc/OpenCL/vendors
NVIDIA-Linux-x86_64-195.36.08-pkg0/etc/OpenCL/vendors/nvidia.icd
NVIDIA-Linux-x86_64-195.36.08-pkg0/usr/lib/libOpenCL.so.1.0.0
NVIDIA-Linux-x86_64-195.36.08-pkg0/usr/include/CL
NVIDIA-Linux-x86_64-195.36.08-pkg0/usr/include/CL/cl.h
NVIDIA-Linux-x86_64-195.36.08-pkg0/usr/include/CL/cl_gl.h
NVIDIA-Linux-x86_64-195.36.08-pkg0/usr/include/CL/cl_platform.h

Additional info:
* package version(s)

nvidia-utils 195.36.08-1

* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Wednesday, 23 June 2010, 10:49 GMT
Reason for closing:  Implemented
Comment by James Snyder (jbsnyder) - Monday, 01 March 2010, 01:17 GMT
I think these diffs should cover it, not sure what the procedure is for submitting patches...

Note: I've updated this diff a few times, this version now includes libnvidia-compiler, which I think is necessary for OpenCL. I am now getting examples from the gpucomputing sdk 3.0 beta building on my system w/ the latest version of this diff.

http://gist.github.com/318989
Comment by Radu Popescu (radumash) - Thursday, 15 April 2010, 18:04 GMT
I think the official package nvidia-utils should contain all the libraries contained in the official installer from the NVIDIA website. I really don't see a point in removing OpenCL and any other libs.
Comment by James Snyder (jbsnyder) - Thursday, 15 April 2010, 18:23 GMT
I think the transition to include these files in standard driver releases is somewhat recent, since the nvidia-utils PKGBUILD includes files in the package by copying specific filenames, it simply ignores this addition. Since as Radu notes, the default nvidia-utils package would install these files, I think it makes sense to update the PKGBUILD to include them.

Loading...