Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18485 - {archweb} Search doesn't trim leading/trailing spaces

Attached to Project: Arch Linux
Opened by Ionut Biru (wonder) - Saturday, 27 February 2010, 13:00 GMT
Last edited by Dan McGee (toofishes) - Wednesday, 12 December 2012, 03:48 GMT
Task Type Bug Report
Category Web Sites
Status Closed
Assigned To Dan McGee (toofishes)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Search doesn't find anything if the keyword contain a space at the end or at the begining
Example:
mercurial<space>
This task depends upon

Closed by  Dan McGee (toofishes)
Wednesday, 12 December 2012, 03:48 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Don't search with spaces. Making search in general more powerful is a separate issue (see: "foo bar").
Comment by Dan McGee (toofishes) - Saturday, 27 February 2010, 14:44 GMT
Working as intended? Don't put a space in there? I'm all about letting people search for *exactly* what they type, I personally hate it when software tries to outsmart the user. Maybe you wanted to look for "mercurial " in a description so you purposely put the space there.

The title is misleading, as a search like this works absolutely fine: http://www.archlinux.org/packages/?q=windows+network
Comment by Dan McGee (toofishes) - Saturday, 27 February 2010, 14:45 GMT
  • Field changed: Summary ({archweb_pub} Search fails if the keyword contain spaces → {archweb} Search doesn't trim leading/trailing spaces)
And archweb_pub is no more, just archweb...
Comment by Ionut Biru (wonder) - Saturday, 27 February 2010, 14:54 GMT
sometimes when i copy and paste some name it has a space at beginning/end and if i remember well, the old archweb was working fine.

that's why i open this bug.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 05 March 2010, 05:02 GMT
+1 For the same reason as wonder.
Comment by Dan McGee (toofishes) - Friday, 05 March 2010, 14:36 GMT
I don't see anything in the prior archweb code that indicates spaces were trimmed, but I'll poke some more.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 05 March 2010, 14:40 GMT
previous behaviour was: at first search with spaces -> result fail, but the search word in textbox was trimmed, so a second search returned results.
Comment by stqn (stqn) - Thursday, 26 August 2010, 12:16 GMT
Related to the original title of this bug, "Search fails if the keyword contain spaces", I find it quite annoying that looking for "foo bar" doesn't return the package "foo-bar". Usually when I'm looking for a package, this is because I don't know its exact name (or maybe I don't even know if it exists.)

Loading...