Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18448 - [networkmanager] fails to stop on shutdown

Attached to Project: Arch Linux
Opened by Francisco Pina (Stunts) - Wednesday, 24 February 2010, 11:38 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 24 February 2010, 22:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When shutting down or restarting the computer, during the daemon stopping stage, the networkmanager daemon fails to stop.
I can stop it just fine from the console.
I can reproduce this in both my x86_64 laptop and on my i686 netbook.
Also this doesn't seem to be affecting anything other than seeing red letters every time I reboot.

Additional info:
* package version(s)
extra/networkmanager 0.8-1

* config and/or log files etc.
Anywhere I can find logs on this?

Steps to reproduce:
Update networmanager to the latest version;
Reboot and watch the [FAIL] message.
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 24 February 2010, 22:48 GMT
Reason for closing:  Not a bug
Comment by Ionut Biru (wonder) - Wednesday, 24 February 2010, 12:37 GMT
post DAEMONS list from rc.conf
Comment by Francisco Pina (Stunts) - Wednesday, 24 February 2010, 13:56 GMT
Here's my DAEMONS list from rc.conf on my laptop:
DAEMONS=(syslog-ng hal @networkmanager alsa @netfs @crond @cups @cpufreq @hdparm readahead-list-desktop)
I don't have my netbook with me, but I will be able to post it tonight.
Comment by Ionut Biru (wonder) - Wednesday, 24 February 2010, 20:35 GMT
you could try adding dbus before hal.

dbus hal @networkmanager
Comment by Francisco Pina (Stunts) - Wednesday, 24 February 2010, 21:49 GMT
I used to have it that way, but it caused an error on startup.
It was also nothing seriuos, just something about dbus already running after starting hal.
I'll be able to test doing that agin tomorow and report back with the complete error message.
Comment by Jan de Groot (JGC) - Wednesday, 24 February 2010, 22:29 GMT
What happens is this:
with DAEMONS=(hal networkmanager), hal will take care of dbus startup. When shutting down, rc.shutdown will check for started daemons that aren't listed in DAEMONS and shuts them down first, so it shuts down dbus. At least networkmanager, and possibly hal, will terminate when dbus quits, which causes FAIL when you shut those daemons down, as they already terminated without using the init script.
Comment by Francisco Pina (Stunts) - Wednesday, 24 February 2010, 22:42 GMT
The suggestion seems to have done the trick.
I have added dbus before hal on my netbook and it solved the problem, right after I pressed shutdown. I didn't even have to reboot with the new settings for it to have effect. It will probably solve my problems with my laptop too.
I just have one question, tough - wasn't hal supposed to call dbus? Shoudn't hal take it down with it on shutdown?
And one more thing - the error message I mentioned in the previous post happens when I start dbus after hal. That was the reason I removed it in the first place.
Thank you for your help!
Comment by Ionut Biru (wonder) - Wednesday, 24 February 2010, 22:48 GMT
@Francisco, Jan already answered to that question.

Loading...