Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18447 - [i8kmon] 1.33-1 looks in wrong file for configuration

Attached to Project: Arch Linux
Opened by Andreas Scholta (brx) - Wednesday, 24 February 2010, 10:47 GMT
Last edited by Eric Belanger (Snowman) - Friday, 11 March 2011, 19:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Roman Kyrylych (Romashka)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

i8kmon in Arch Linux checks for /etc/i8kutils/i8kmon.conf.conf by default.
The configuration file is actually located at /etc/i8kutils/i8kmon.conf however.


Additional info:

Problem exists in version 1.33-1 of i8kmon. I have don't know about other versions.


Steps to reproduce:

Problem exists by default.
This task depends upon

Closed by  Eric Belanger (Snowman)
Friday, 11 March 2011, 19:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in i8kmon-1.33-2. I also added a /etc/conf.d/i8kmon to send options to the daemon.
Comment by orbisvicis (orbisvicis) - Wednesday, 24 March 2010, 03:52 GMT
I couldn't figure this out until I took a look at the PKGBUILD, it uses sed to modify some of the paths hardcoded in "./i8kmon"

- in "./i8kmon" line 28
sysconfig /etc/i8kmon.conf
- becomes
sysconfig /etc/i8kutils/i8kmon.conf.conf
- after applying
sed -i 's|/etc/i8kmon|/etc/i8kutils/i8kmon.conf|g'

Since as far as I can tell there is only one occurance of "/etc/i8kmon" in "./i8kmon" the PKGBUILD should modify the sed line to:
sed -i 's|/etc/i8kmon|/etc/i8kutils/i8kmon|g' i8kmon || return 1

As far as I can tell "./i8kmon.1" - referred in the previous sed line of the PKGBUILD - is fine since it is already missing the ".conf" suffixes.

So, now can someone please fix this before my laptop/space-heater burns up :)
Comment by orbisvicis (orbisvicis) - Saturday, 10 April 2010, 21:47 GMT
...
Comment by orbisvicis (orbisvicis) - Saturday, 10 April 2010, 22:34 GMT
...
Comment by Nick (clu) - Wednesday, 20 October 2010, 21:09 GMT
I am also effected by this issue.

Loading...