Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18416 - [networkmanager] privoxy 3.0.16-1 fails to start at boot time

Attached to Project: Arch Linux
Opened by Heiko Baums (cyberpatrol) - Sunday, 21 February 2010, 02:09 GMT
Last edited by Andrea Scarpino (BaSh) - Saturday, 18 June 2011, 08:39 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
privoxy 3.0.16-1 fails to start at boot time. Starting it manually by `/etc/rc.d/privoxy start` after logging in is working.

This is the content of /var/log/privoxy/log:
Feb 21 02:43:42.779 7f9b15ee1700 Fatal error: can't bind to 127.0.0.1:8118: The hostname is not resolvable

This is my DAEMONS array:
DAEMONS=(syslog-ng cpufreq acpid dbus hal networkmanager postfix alsa crond cups privoxy hddtemp sensors lircd gpm fbsplash)

So privoxy is started after every network related daemons especially networkmanager.

This is either a bug in privoxy or in networkmanager 0.8-1.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Saturday, 18 June 2011, 08:39 GMT
Reason for closing:  No response
Comment by Heiko Baums (cyberpatrol) - Sunday, 21 February 2010, 02:18 GMT
It's indeed a bug in networkmanager 0.8-1.

After replacing networkmanager with network in the DAEMONS array privoxy is started correctly again at boot time:
DAEMONS=(syslog-ng cpufreq acpid dbus hal network firewall postfix alsa crond cups privoxy hddtemp sensors lircd gpm fbsplash)
Comment by Rorschach (Rorschach) - Sunday, 21 February 2010, 10:07 GMT
Well I think the problem is the following: network is running in the foreground, establishing a network connection and then sysinit goes on. When now privoxy is started, a network connection is up and running, the hostname is set and privoxy can resolve the hostname and everything is fine. If you use networkmanager it's not sure that a network connection has already been setup when privoxy is started or as it seems the hostname has been set. Most likly it's not and thus this error-message.

The way to solve this is starting privoxy as dispatcher script (http://wiki.archlinux.org/index.php/NetworkManager#Configure_network_services).
Comment by Ionut Biru (wonder) - Sunday, 21 February 2010, 12:02 GMT
localhost is bring up by init script and networkmanager shouldn't affect this.

maybe check your /etc/hosts and see if 127.0.0.1 has localhost hostname
Comment by Heiko Baums (cyberpatrol) - Sunday, 21 February 2010, 13:59 GMT
localhost shouldn't have anything to do with any network connections, because it's the loopback network and the own computer. localhost must be up even if there's no network connection at all. So putting privoxy as dispatcher should not be necessary because privoxy doesn't try to bind to a LAN or WAN IP but only to localhost. Not only privoxy relies on localhost but many other programs which don't need a network connection at all, too.

My /etc/hosts is correct, has not been changed and has worked and is working correctly before and after the last update. And if /etc/hosts was the problem then the issue would not only appear with the new networkmanager but also with network and it would have happened before the last update.

And this issue only appears after the last system update which included an update of privoxy to 3.1.6-1 and networkmanager to 0.8-1, and it doesn't happen with network. So this must be a bug in networkmanager.
Comment by Jan de Groot (JGC) - Monday, 22 February 2010, 15:23 GMT
Networkmanager used to rewrite /etc/hosts and/or change your hostname, but we patched that away.
Comment by Heiko Baums (cyberpatrol) - Monday, 22 February 2010, 15:32 GMT
So there's either an issue with this patch or with networkmanager itself.

The only thing I saw in my /etc/hosts yesterday was that the line for localhost was moved to the top of the file above the comments. But the line itself, every other lines and the order of the lines haven't been changed.
Comment by orbisvicis (orbisvicis) - Thursday, 25 February 2010, 02:28 GMT
I do not have this issue, and I also run both NetworkManager and privoxy. Also, NetworkManager continues to modify the hosts file though it now keeps the hostname the same.
Comment by orbisvicis (orbisvicis) - Thursday, 25 February 2010, 16:22 GMT Comment by Heiko Baums (cyberpatrol) - Thursday, 11 March 2010, 00:41 GMT
I looked into this again. This must have something to do with networkmanager. I think it's because networkmanager is doing something with the connection, so that other software is not able to bind to localhost for a short time.

I moved privoxy directly behind networkmanager in the DAEMONS array and now privoxy starts again at boot time.

This was the old DAEMONS array with which privoxy didn't start:
DAEMONS=(syslog-ng cpufreq acpid dbus hal networkmanager postfix alsa crond cups privoxy hddtemp sensors lircd gpm fbcondecor)

With this DAEMONS array privoxy always starts again:
DAEMONS=(syslog-ng cpufreq acpid dbus hal networkmanager privoxy postfix alsa crond cups hddtemp sensors lircd gpm fbcondecor)
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 13 August 2010, 03:48 GMT
  • Field changed: Status (Assigned → Waiting on Response)
status of this issue with latest packages?
Comment by Darin (omgwtfbyobbq) - Thursday, 09 September 2010, 09:42 GMT
I had the same issue w/ wicd fwiw. If I start privoxy before wicd it's fine, but if I start it after it fails to start and complains about the hostname.
Comment by Jelle van der Waa (jelly) - Friday, 15 April 2011, 10:29 GMT
any update?
Comment by JM (fijam) - Saturday, 28 May 2011, 21:58 GMT
No response, candidate for closing.

Loading...