Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#1839 - No dircolors

Attached to Project: Arch Linux
Opened by Lukas Sabota (punkrockguy318) - Friday, 26 November 2004, 01:12 GMT
Last edited by arjan timmerman (blaasvis) - Sunday, 06 March 2005, 18:14 GMT
Task Type Feature Request
Category Packages: Current
Status Closed
Assigned To Judd Vinet (judd)
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In most linux distributions, /etc/profile will set the LS_COLORS using dir_colors. Arch does not do this. The default place for colours are /etc/DIR_COLORS and ~/.dir_colors. To make Arch look for these files, something similar to this would need to be added to /etc/profile:

eval `dircolors /etc/DIR_COLORS`
eval `dircolors ~/.dir_colors

Tests to see if the file is there must be added, I'll leave that up to you.
Thank you!
This task depends upon

Closed by  arjan timmerman (blaasvis)
Thursday, 23 March 2006, 07:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  i look @ the DIR_COLORS and my console and it works now.
Comment by Raven Morris (Samus_Aran) - Friday, 28 January 2005, 02:55 GMT
I agree that this is missing. I had to manually add this.
Comment by Simo Leone (neotuli) - Sunday, 06 March 2005, 18:13 GMT
Welcome to Arch -- not a bug
Comment by Damir Perisa (damir.perisa) - Sunday, 06 March 2005, 18:24 GMT
2005-03-06 - bug squashing day discussion:
conclusion:

- DIR_COLORS (attached to this bug) should go to coreutils pkg
- /etc/profile should eval ~/.dir_colors and if not existant /etc/DIR_COLORS
Comment by Jason Chu (jason) - Sunday, 06 March 2005, 18:26 GMT
Isn't there a DIR_COLORS file distributed with coreutils?
Comment by Jason Chu (jason) - Sunday, 06 March 2005, 18:30 GMT
i3839 is afraid the defaults will change. Please don't make him cry.
Comment by Jason Chu (jason) - Sunday, 06 March 2005, 18:38 GMT
Is it easy to figure out what should go into a DIR_COLORS?

Should we just not include a default file but have the logic?
Comment by Greg Meyer (oggb4mp3) - Wednesday, 31 August 2005, 03:45 GMT
Interestingly, dir listings are made in color even though LS_COLORS is not set. How is this accomplished?
Comment by arjan timmerman (blaasvis) - Friday, 20 January 2006, 13:54 GMT
status ?

Loading...