Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18357 - [openoffice-base] Help not working right

Attached to Project: Arch Linux
Opened by Douglas McFadzean (ninian) - Tuesday, 16 February 2010, 10:09 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 19 February 2011, 16:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

If I run OpenOffice 3.2 (using the soffice command) and immediately access Help from the menu, it shows fine. If I then open a new text document, and access Help, it shows fine. But if I open an existing document and access Help, it only shows the Contents and Index listings in the left-hand Help pane - nothing appears in the right-hand pane whatsoever! (And it only works again when the program is restarted.)

As soon as the Help doesn't work, the following error messages arise:

rdf_storage.c:684: (librdf_free_storage) assertion failed: object pointer of type librdf_storage is NULL.
rdf_model.c:395: (librdf_free_model) assertion failed: object pointer of type librdf_model is NULL.
error
Local file read for file:///usr/lib/openoffice/basis-link/help/main_transform.xsl refused
error
xsltParseStylesheetFile: read rights for file:///usr/lib/openoffice/basis-link/help/main_transform.xsl denied

Additional info:

Package version is: openoffice-base 3.2.0-1
User profile: existing or newly created - doesn't matter

Steps to reproduce:

As above, for example, issuing from console: soffice -writer
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 19 February 2011, 16:29 GMT
Reason for closing:  Works for me
Comment by Jan de Groot (JGC) - Tuesday, 16 February 2010, 11:12 GMT
Works fine here. What are the permissions on /usr/lib/openoffice/basis-link/help/main_transform.xsl? Can you read it as regular user?
Comment by Douglas McFadzean (ninian) - Tuesday, 16 February 2010, 11:54 GMT
File /usr/lib/openoffice/basis-link/help/main_transform.xsl is owned by root:root with permissions 444, and is accessible by user.
Note that the problem still occurs:
- with a new user profile
- with a reinstallation of the openoffice-base package
- when the permissions of /usr/lib/openoffice/basis-link/help/main_transform.xsl are changed to 666
- regardless of the document file opened
- on different computers (with latest Arch upgrades)
Comment by Andreas Radke (AndyRTR) - Tuesday, 16 February 2010, 17:26 GMT
Ok, I can confirm it in all Vanilla OOo packages up to the devel one. I'll check the go-oo later.
Comment by Andreas Radke (AndyRTR) - Thursday, 18 March 2010, 19:57 GMT
Help is working in go-openoffice. Let's investigate what might be the reason breaking it in vanilla OOo.
Comment by Andreas Radke (AndyRTR) - Monday, 22 March 2010, 21:52 GMT
Please check if this is solved in openoffice-base-devel 3.3_dev300_m75-2, that doesn't use our system librdf(redland/rasqal/raptor).
Comment by Heiko Baums (cyberpatrol) - Monday, 22 March 2010, 22:49 GMT
For me it seems to be fixed in openoffice-base-devel 3.3_dev300_m75-2.
Comment by Tristan Wang (Bodhi) - Tuesday, 30 March 2010, 03:38 GMT
Besides, it happens when creating new text docs from the customized template.
Comment by Andreas Radke (AndyRTR) - Tuesday, 30 March 2010, 09:19 GMT
http://www.openoffice.org/issues/show_bug.cgi?id=108911 - fix available. I'll delay it a bit. It doesn't look a big issue so far and you can use the -beta pkg that should be fixed.
Comment by Andreas Radke (AndyRTR) - Wednesday, 31 March 2010, 12:36 GMT
The above fix doesn't solve this particular issue. Filed another bug upstream:

http://qa.openoffice.org/issues/show_bug.cgi?id=110523
Comment by Andreas Radke (AndyRTR) - Saturday, 10 April 2010, 10:27 GMT
For workaround the current packages don't use system redland. Does it work now for you?
Comment by Heiko Baums (cyberpatrol) - Saturday, 10 April 2010, 13:04 GMT
How do I disable it for openoffice?
Comment by Andreas Radke (AndyRTR) - Saturday, 10 April 2010, 13:09 GMT
openoffice-base 3.2.0-3 is built to use the redland/librdf/rasqal sources that are shiped within the OOo sources. So bugs caused by our incompatible ArchLinux redland library should have gone now. Can you confirm it? (There's nothing to change. Just try it out again)
Comment by Douglas McFadzean (ninian) - Saturday, 10 April 2010, 16:48 GMT
Help in openoffice-base 3.2.0-3 seems to work fine for me now.
Many thanks for fixing this!
Comment by Heiko Baums (cyberpatrol) - Saturday, 10 April 2010, 17:10 GMT
For me it's working, too. Thanks.
Comment by Douglas McFadzean (ninian) - Thursday, 10 June 2010, 19:22 GMT
As reported at http://bbs.archlinux.org/viewtopic.php?pid=772512#p772512, a similar problem has returned with the openoffice-base 3.2.1-1 (i686) package (though no error message is reported if soffice run from command line).
Comment by Olive (olivel) - Saturday, 12 June 2010, 12:24 GMT
I can confirm this bug with openoffice 3.2.1-1. (exactly the situation of the original message) and I have the following error messages:

error
Local file read for file:///usr/lib/openoffice/basis-link/help/main_transform.xsl refused
error
xsltParseStylesheetFile: read rights for file:///usr/lib/openoffice/basis-link/help/main_transform.xsl denied

in the console

The two files are readable (moreover I have tried to launch openoffice as root to be sure it is not a permission problem and exactly the same problem occurs).
Comment by Andreas Radke (AndyRTR) - Saturday, 12 June 2010, 19:34 GMT
please file a new issue upstream and CC me.
Comment by Olive (olivel) - Friday, 02 July 2010, 14:27 GMT
Just to confirm that the official build (3.2.1) works fine. Is it really an upstream bug?
Comment by Andreas Radke (AndyRTR) - Saturday, 30 October 2010, 15:26 GMT
Is there still something broken? How's state with current rebuilt vanilla OOo(stable,beta,devel) hitting testing tonight and new libreoffice?
Comment by Douglas McFadzean (ninian) - Saturday, 30 October 2010, 15:55 GMT
Help working fine for me (system fully updated) in new LibreOffice (3.2.99.2-1) from extra repo.
(Am not now using OOo from repos so can't comment on it.)
Comment by Doug (archix) - Monday, 22 November 2010, 07:42 GMT
This issue is occuring in the current vanilla openoffice-base 3.2.1-3 package. Same error messages:
Local file read for file:///usr/lib/openoffice/basis-link/help/main_transform.xsl refused
error
xsltParseStylesheetFile: read rights for file:///usr/lib/openoffice/basis-link/help/main_transform.xsl denied
Comment by Andreas Radke (AndyRTR) - Monday, 22 November 2010, 07:43 GMT
Please test the openoffice-base-beta pkg and the libreoffice pkg from extra.
Comment by Heiko Baums (cyberpatrol) - Monday, 22 November 2010, 17:50 GMT
Works with libreoffice.
Comment by Doug (archix) - Tuesday, 23 November 2010, 04:05 GMT
openoffice-base-beta-3.3.0_ooo330_m16-1 works fine.
The help content is present after loading a saved file.
There were no errors printed to console after running "soffice-beta -writer"
Comment by Doug (archix) - Saturday, 11 December 2010, 21:00 GMT
The vanilla openoffice-base 3.2.1-4 package exhibits this problem (tried x86_64 and i686).
Comment by mkkot (mkkot) - Saturday, 15 January 2011, 17:19 GMT
Same here. 32 bit, xfce, lightweight system for my laptop.
Comment by Andreas Radke (AndyRTR) - Saturday, 12 February 2011, 23:34 GMT
Is this solved in LibO 3.3.0.4 and OOo 3.3.0?
Comment by Douglas McFadzean (ninian) - Sunday, 13 February 2011, 00:49 GMT
Okay with me and libreoffice 3.3.0.4-2 on Openbox.
Comment by Andreas Radke (AndyRTR) - Saturday, 19 February 2011, 16:29 GMT
Help index is working well for me with openjdk6 + lucene in

[root@workstation64 andyrtr]# pacman -Q openoffice-base libreoffice
openoffice-base 3.3.0-1
libreoffice 3.3.1rc2-1

Closing this as works for me.

Loading...