Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#18354 - [lxde] Keyboard Layout Switcher worked only for one session!

Attached to Project: Community Packages
Opened by Sia (Sia) - Tuesday, 16 February 2010, 01:24 GMT
Last edited by Thomas Dziedzic (tomd123) - Sunday, 12 December 2010, 21:07 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jürgen Hötzel (juergen)
Angel Velasquez (angvp)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


As i add the 'Keyboard Layout Switcher' to the panel in LXDE, worked fine just for this session, but after reboot the machine is only one layout is shown and this is US American (although my Layout is DK and DE). I must delete it from panel and added it again.
Additional info:
* package version(s)
* config and/or log files etc.
lxappearance 0.4.0-2
lxsession-lite 0.4.1-1
Steps to reproduce:
This task depends upon

Closed by  Thomas Dziedzic (tomd123)
Sunday, 12 December 2010, 21:07 GMT
Reason for closing:  Works for me
Additional comments about closing:  works and no reply
Comment by Jürgen Hötzel (juergen) - Wednesday, 17 February 2010, 17:50 GMT
Please upload your xorg.conf and .config/lxpanel/LXDE/panels/panel file.
Comment by Sia (Sia) - Thursday, 18 February 2010, 00:53 GMT
I didn't use xorg.conf file, i use HAL in /etc/hal/fdi/policy/10-keymap.fdi.
Her is my .config/lxpanel/LXDE/panels/panel file:
Comment by Jürgen Hötzel (juergen) - Friday, 19 February 2010, 21:29 GMT
So this is part of your fdi file:

<merge key="input.xkb.layout" type="string">dk,de</merge>

Any STDERR output? Maybe start lxpanel --profile LXDE from terminal. xkb-plugin does some error-reporting.
Comment by Sia (Sia) - Saturday, 20 February 2010, 09:38 GMT
the FDI file part:
<merge key="input.xkb.layout" type="string">dk,iq</merge>
<merge key="input.xkb.variant" type="string"> ,ku_ara</merge>
<merge key="input.xkb.options" type="string">grp:alt_shift_toggle</merge>
i use dk,iq ku_ara for kurdish in arabic script.

$ lxpanel --profile LXDE
There is already an instance of LXPanel. Now to exit
Comment by Jürgen Hötzel (juergen) - Saturday, 20 February 2010, 09:52 GMT
Please do
"pkill lxpanel" and try to start it from terminal capturing STDERR
Comment by Sia (Sia) - Saturday, 20 February 2010, 10:29 GMT
lxpanel is killed and starting again, but what you mean with STDERR?
Comment by Jürgen Hötzel (juergen) - Saturday, 20 February 2010, 11:53 GMT
Any output on the terminal, when lxpanel is started and the xkb plugin is initialized?
Comment by Sia (Sia) - Saturday, 20 February 2010, 12:30 GMT
Comment by Jürgen Hötzel (juergen) - Sunday, 21 February 2010, 20:09 GMT
I just made a new release which includes xkb fixes: 0.5.5-2

Please try and report
Comment by Sia (Sia) - Tuesday, 23 February 2010, 10:52 GMT
Is little bit better :) after restart is still US flag but if i toggle Shift + Alt changed to the correct one.
Comment by Thomas Dziedzic (tomd123) - Saturday, 03 July 2010, 22:50 GMT
Comment by Angel Velasquez (angvp) - Thursday, 08 July 2010, 17:41 GMT

Are you still having this bug again?

I am tempting to close this bug report, and if it appears again, re-open it..
Comment by Sia (Sia) - Friday, 09 July 2010, 09:46 GMT
What you mean with "again"?
The bug isn't fixed before.
Comment by Angel Velasquez (angvp) - Friday, 09 July 2010, 11:21 GMT
We asked you 'bout status and you didn't reply, I should use 'yet' instead again,

Could you describe the steps to reproduce the bug and paste your configs again? (in order to find a solution)

Comment by Sia (Sia) - Saturday, 10 July 2010, 09:42 GMT
Is funny to try teach other people "How they report a bug"
Comment by Thomas Dziedzic (tomd123) - Saturday, 10 July 2010, 13:33 GMT
I don't think you understood him.
He is trying to help you and he just can't reproduce what you're experiencing.
You haven't given him ANY useful information since he asked you.
Be helpful if you want to see this bug get fixed and not closed.
Comment by Thomas Dziedzic (tomd123) - Friday, 10 December 2010, 17:00 GMT
status? if no reply, will close tomorrow.