Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18349 - [cryptsetup] udev rules block opening devices

Attached to Project: Arch Linux
Opened by Ray (ataraxia) - Monday, 15 February 2010, 18:47 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 30 June 2010, 15:45 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Very often, when doing a "cryptsetup luksOpen", I see this message:

device-mapper: remove ioctl failed: Device or resource busy

and in syslog, there is this message:

2010-02-15T10:07:03-05:00 <kern.warning> amaranth kernel: device-mapper: ioctl:
unable to remove open device temporary-cryptsetup-30525

Normally it works fine when it retries 1 second later, but sometimes it fails again.

This only started happening recently, after the upgrade to cryptsetup 1.1.0 and device-mapper 2.02.60.

There are mentions of it atlinux-crypto@vger.kernel.org/msg04072.html"> http://www.mail-archive.com/linux-crypto@vger.kernel.org/msg04072.html and http://code.google.com/p/cryptsetup/issues/detail?id=38 . One of these implies that there are some bogus udev rules somewhere, which is why it seemed appropriate to report this to Arch as a packaging/integration issue rather than directly upstream.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 30 June 2010, 15:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  cryptsetup 1.1.2
Comment by Thomas Bächler (brain0) - Monday, 15 February 2010, 21:06 GMT
Find it :) I can't find it, we have device-mapper devices handled in upstream udev rules from the device-mapper package and all others that might touch it (i.e. devicekit) should also be adjusted by now.
Comment by Thomas Bächler (brain0) - Wednesday, 05 May 2010, 17:30 GMT
Please try the device-mapper and cryptsetup packages from testing (make sure to upgrade initscripts as well, or it won't boot). This problem should be gone there.
Comment by Ray (ataraxia) - Wednesday, 05 May 2010, 18:07 GMT
You are right, the problem is fixed with cryptsetup-1.1.1_rc2-1 and device-mapper-2.02.64-1.
Comment by Thomas Bächler (brain0) - Wednesday, 05 May 2010, 18:12 GMT
Great. As soon as 1.1.1 final is released and moved to core, we can close this bug.

Loading...