Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18344 - [xf86-video-intel] can't wake from suspend

Attached to Project: Arch Linux
Opened by Mateusz Tracz (matiit) - Monday, 15 February 2010, 16:26 GMT
Last edited by Allan McRae (Allan) - Saturday, 28 April 2012, 16:10 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: I've newest packages from extra, using gnome without gnome-screensaver, when i'm waking from suspend there is only black screen, can't do anything but reboot.

Additional info:
* package version(s) xf86-video-intel 2.10.0-1 kernel with KMS (this intel driver's version only supports kms i think)

* config and/or log files etc.


Steps to reproduce:
Suspend
Try to wake
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 28 April 2012, 16:10 GMT
Reason for closing:  No response
Comment by Ivan Bulatovic (combuster) - Friday, 19 February 2010, 19:57 GMT
It's an upstream bug afaik, it's resolved in 2.6.33-rc8 kernel version. It would help to post your chipset type, GM945 or... ?
Comment by Mateusz Tracz (matiit) - Saturday, 20 February 2010, 12:23 GMT
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
That's what i have

i have own built kernel so i will upgrade it and write if it helps
Comment by Mateusz Tracz (matiit) - Thursday, 25 February 2010, 16:52 GMT
I compiled 33-rc8 kernel and problem still exist
Comment by Mateusz Tracz (matiit) - Saturday, 13 March 2010, 12:57 GMT
Any tips?
Comment by Mateusz Tracz (matiit) - Saturday, 27 March 2010, 09:59 GMT
I've compiled 2.6.34-rc2 and it's still no change. On kernel26 from extra it's not work too;/
Comment by Clemens Lutz (tkdfighter) - Thursday, 15 April 2010, 16:14 GMT
Is this what you are experiencing: https://bugs.launchpad.net/linux/+bug/532374 ? This is the problem I'm having on my X201 Thinkpad using Arch.
Comment by QQQ (Saunad) - Tuesday, 18 January 2011, 18:45 GMT
I have had this issue on Thinkpad X30 (Intel 82830 CGC) since KMS became mandatory. Still exists with xf86-video-intel 2.14.0-1. Kernel is 2.6.36-ARCH.

Had to resort to xf86-video-intel <2.10, and with that xorg-server < 1.8 and i915.modeset=0.
Comment by Damien Gombault (Desintegr) - Wednesday, 01 June 2011, 10:41 GMT
Maybe try this script : http://ubuntuforums.org/showpost.php?p=6105510&postcount=12

It fixes my resume problem (black screen).
Comment by Jelle van der Waa (jelly) - Saturday, 14 January 2012, 19:22 GMT
Status?

Loading...