Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18298 - [xf86-video-intel] makes KMS bug on i915 reappear

Attached to Project: Arch Linux
Opened by Vincent (vinvin) - Thursday, 11 February 2010, 22:18 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 09 November 2010, 11:10 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 16
Private No

Details

The new intel video driver only accepts KMS enabled kernels. It would not be something bad if KMS was not working on intel laptop graphic chipsets, like the i915 which is in EeePC 900. Unfortunately, it is unable to wake up from sleep.
It was reported 10 months ago to upstream, but nobody seems to care: http://bugzilla.kernel.org/show_bug.cgi?id=13144

Until now, I was still using a KMS disabled kernel, but now I have to halt my laptop everytime I want it to sleep, which is very inconvenient.

I guess all I can do is to get the old package for downgrade and be stuck with it, but at least you'll know that it was not a 100% good idea to replace it. It also means that Arch is not working properly anymore on EeePC and others.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 09 November 2010, 11:10 GMT
Reason for closing:  Fixed
Comment by Alexander Drozdov (adrozdov) - Friday, 12 February 2010, 02:53 GMT
I confirm it.

We can use fbdev as x-org driver, but it has a lot of restriction:
* we does not have XVideo, so, we have very slow video playing
* we does not have RANDR, so, we can not connect external monitor or projector (I use it functionality for a long time)
* we does not have GL...
* we does not have ...
Comment by Renato Florentino Garcia (renato_garcia) - Friday, 12 February 2010, 08:36 GMT
I have a Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller, which uses the i915 module, and frequently the screen flicker and sometimes I get a black screen and computer lock, when using KMS. Before I am disabling the KMS when in grub, but this is not posible with this version.
Comment by Guillaume DE BURE (gdebure) - Friday, 12 February 2010, 20:58 GMT
Same behaviour as Renato here... However, is this the same bug as the one in the tile ? Or should we open a new one ?
Comment by Stefano (kki) - Saturday, 13 February 2010, 15:22 GMT
confirmed also here on my dell mini 9:
after a suspend/resume, the screen flicker random every 2-5mins after that it goes black and all stop working
no ALT+CTRL+Fn, the only solution is hw reset :-/
For now i'm back to 2.9.x xf86-video-intel driver and set to ignore into pacman.conf, also on grub disabled kms
(is this the problem, when disabled all problems gone).
please solve this otherwise is impossible for me to use arch if every time i'd to switch it off/on and not suspend...
Thanks!

root ~ # uname -a
Linux l0cmini 2.6.32-ARCH #1 SMP PREEMPT Tue Feb 9 14:46:08 UTC 2010 i686 Intel(R) Atom(TM) CPU N270 @ 1.60GHz GenuineIntel GNU/Linux

root ~ # lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
02:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller
02:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
03:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
Comment by Garron (garron) - Sunday, 14 February 2010, 04:27 GMT
I was having this same issue too, someone on the Arch forums (can't seem to locate the thread) suggested adding i915.powersave=0 to the kernel options (while leaving KMS enabled). So far, it looks like that has fixed the problem for me. It didn't work for the person who started the forum thread, unfortunately, so YMMV.
Comment by Adria Arrufat (swiftscythe) - Sunday, 14 February 2010, 06:40 GMT
@Garron: Hi! I think the thread you are talking about is this one:
http://bbs.archlinux.org/viewtopic.php?id=90914
It's one of the last comments on page 2
Comment by Stefano (kki) - Sunday, 14 February 2010, 08:49 GMT
@Garron seems it does work also form me :-) thanks for tips!
Comment by Guillaume DE BURE (gdebure) - Sunday, 14 February 2010, 17:26 GMT
@Garron: Works here also :) Glad to have a stable system again, thanks !
Comment by Vincent (vinvin) - Sunday, 14 February 2010, 17:33 GMT
Thanks for the advice Garron, it's a good thing to have the system working with KMS.
However, does anyone know if powersave=0 mean that the video chipset is not put into sleep mode and thus still continues to be powered when the computer is sleeping? Because if the solution is not to make the computer go into sleep mode when the lit is closed, it's not much of a solution.
Comment by Stefano (kki) - Monday, 15 February 2010, 05:51 GMT
@Vincent i see behaviour as aspected for the sleep function, so no problem at all.
Comment by Vincent (vinvin) - Monday, 15 February 2010, 19:50 GMT
Stefano: maybe the behaviour is good but power still drawn. It could be interesting to see the code of the driver to see what it does with powersave=0.

Anyway, I just tested the i915.powersave=0 option on my EeePC and it does not make it work on wake up.
Comment by Stefano (kki) - Monday, 15 February 2010, 20:05 GMT
@Vincent here it does work ok, also battery drain is 'as before updates', wake up correctly.
Comment by Isaac Dupree (idupree) - Monday, 08 March 2010, 04:50 GMT
@Renato_garcia's issue: it sounds like http://bugs.freedesktop.org/show_bug.cgi?id=26266 which affects me and means I've downgraded video-intel so I can use non-KMS. I have not, however, tried powersave=0, and I'm waiting to see if the .33 kernel behaves any differently...
Comment by Alexander Drozdov (adrozdov) - Monday, 08 March 2010, 05:03 GMT
Guys!

on kernel 2.6.32.9 with latest xf86-video-intel all work well on my EeePC 1000HA.
For info, my /etc/modprobe.d/i915.conf:
options i915 modeset=1 powersave=1 fbpercrtc=1

on kernel 2.6.32.8 it was fails.
Comment by Vincent (vinvin) - Monday, 08 March 2010, 10:40 GMT
Thanks for the reports Isaac and Alexander. I've found this thread on the forum which talks about the same problem: http://bbs.archlinux.org/viewtopic.php?pid=707610
It seems that the powersave option is good for most people, but still not for me (915m - eeepc900). I'll post on your bug report on freedesktop.
Comment by Alexander Drozdov (adrozdov) - Monday, 08 March 2010, 10:56 GMT
Vincent, what is your kernel/xf86-video-intel versions?
Comment by Vincent (vinvin) - Monday, 08 March 2010, 11:04 GMT
Well it's last versions of Arch stable: kernel-eee version 2.6.33-2 (eee compilation options from toofishes.net) and 2.10.0-1 for xf86-video-intel.
Comment by Alexander Drozdov (adrozdov) - Monday, 08 March 2010, 11:10 GMT
Could you please test on stock kernel? It is interesting to me :-) I use stock kernel from core repository.
Comment by Vincent (vinvin) - Monday, 08 March 2010, 11:18 GMT
Yes, I have the same problem with flickering, bad resolution, and black screen, as described on the freedesktop bug report, even with i915.powersave=0.
Comment by Mateusz Tracz (matiit) - Saturday, 27 March 2010, 10:04 GMT
Me too have a problem with awaking from suspend and hibernate
Comment by Vincent (vinvin) - Sunday, 28 March 2010, 00:37 GMT
Unfortunately matiit, the bug has been marked as resolved on freedesktop (http://bugs.freedesktop.org/show_bug.cgi?id=26266) because it's now working for most people. So it's unlikely that it will ever get fixed.
Comment by Thomas Dziedzic (tomd123) - Monday, 28 June 2010, 20:54 GMT
upstream marked it as fixed, status?
Comment by Vincent (vinvin) - Monday, 28 June 2010, 21:40 GMT
Still no change for me Thomas.
What is your upstream anyway? On https://bugzilla.kernel.org/show_bug.cgi?id=13144 nothing changed, and it appears that on http://bugs.freedesktop.org/show_bug.cgi?id=26266 it's not the same bug actually, this one was after some time of use, whereas the first (and my problem) is just after wake up.
Comment by Thomas Dziedzic (tomd123) - Monday, 28 June 2010, 21:44 GMT
I was looking at the latter link
Comment by Alexander Drozdov (adrozdov) - Tuesday, 29 June 2010, 01:05 GMT
Hi All,

Currently I use Last intel-video driver from core repo (2.11.0, any way 2.12.0 is avail, but in testing present 2.11.901 only) and latest kernel (2.6.34) - currenly all ok with video.
Comment by Renato Florentino Garcia (renato_garcia) - Tuesday, 03 August 2010, 23:29 GMT
Here too, all ok to me. I'm using 2.12.0
Comment by Vincent (vinvin) - Wednesday, 01 September 2010, 08:42 GMT
I'm sorry but it's still not working with latest versions (linux-2.6.35.4 and xf86-video-intel-2.12.0). For people who reported it working, maybe you have a more recent version of the chipset, like a 945, but on my 915 I still get a black screen on resume on the ttys and only the mouse in X.
Comment by Vincent (vinvin) - Tuesday, 09 November 2010, 11:05 GMT
Okay I finally found out what was the problem. I had an old version of the /etc/acpi/suspend2ram.sh file and it was doing something wrong, I'm not sure what. Anyways, I have updated it and suspend is indeed working fine now, as well as connecting a monitor to the VGA output.
Sorry for the delay, inconvenience, and wrong information. You can close the bug.

Loading...