Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18260 - [soprano] breaks kde desktop

Attached to Project: Arch Linux
Opened by Federico Chiacchiaretta (baghera) - Tuesday, 09 February 2010, 21:05 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 11 February 2010, 14:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Andrea Scarpino (BaSh)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Hi,
I upgraded to soprano 2.4.0-1 and I found that dolphin doesn't open up anymore, I tried to logout and it failed (it hung with a black screen).
So I rebooted system and I can't login anymore, it stalls on the splash screen.
Downgrading to previous version solved the issue (version 2.3.73-1).

Additional info:
* 2.4.0-1
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 11 February 2010, 14:43 GMT
Reason for closing:  Fixed
Additional comments about closing:  soprano 2.4.0.1
Comment by Andrea Scarpino (BaSh) - Tuesday, 09 February 2010, 21:33 GMT
I cannot reproduce your issue here on x86_64. Can you paste dolphin output runned by terminal?
Comment by Andrea Scarpino (BaSh) - Tuesday, 09 February 2010, 21:39 GMT
anyway, sounds as a duplicate of  FS#18199 
Comment by Federico Chiacchiaretta (baghera) - Tuesday, 09 February 2010, 21:40 GMT
Here is the output, just updated and run dolphin.
Comment by Andrea Scarpino (BaSh) - Tuesday, 09 February 2010, 21:44 GMT
can you try with a new configuration?
Comment by Federico Chiacchiaretta (baghera) - Tuesday, 09 February 2010, 21:54 GMT
Ok, I found it. I started with a new user, then upgraded soprano and dolphin started correctly. Then I went to Systemsettings -> Desktop Search and disabled nepomuk (as I do with the main user), then trying again to start dolphin failed.
Try to reproduce it, I guess it won't work for you too.
Comment by Sven-Hendrik Haase (Svenstaro) - Wednesday, 10 February 2010, 00:43 GMT
Is this related to krunner not starting ( FS#18263 )?
Comment by Andrea Scarpino (BaSh) - Wednesday, 10 February 2010, 00:46 GMT
yes, Pierre is downgrading soprano.
Comment by Panos Filip (Flamelab) - Wednesday, 10 February 2010, 01:05 GMT
Is soprano going to be downgraded on the repos? Same issue here, upgrading from kde-unstable (which was transferred to [testing]) KDE SC. With latest soprano, no dolphin and krunner--> they both won't work. With previous soprano (and previous kdelibs pkgrel), everything OK.
Comment by Pierre Schmitz (Pierre) - Wednesday, 10 February 2010, 01:53 GMT
Yes, you will get the old soprano when you update. This is only a temporary solution though, but gives us time to look into this.
Comment by Michael Trunner (trunneml) - Wednesday, 10 February 2010, 10:14 GMT
The downgrade fixes my problem with krunner, too.
An strace on krunner shows that he wait for a DBus response.

Update: Login and kmail has worked for me.

Loading...