Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18244 - [dansguardian] Remove dependency: squid

Attached to Project: Arch Linux
Opened by Andreas Tiemeyer (grey) - Monday, 08 February 2010, 22:18 GMT
Last edited by Allan McRae (Allan) - Saturday, 02 June 2012, 11:54 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Kevin Piche (kpiche)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: dansguardian currently depends on squid, but it can be built and run without squid

Additional info:
* package version(s) 2.10.1.1-1
* config and/or log files etc.

dansguardian needs a proxy server, but there are several options available: I'm using tinyproxy, others point to polipo. So I would like to see the dependency on squid removed, and a post-install message added that the user needs to install a proxy server of their choice.

Steps to reproduce:
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 02 June 2012, 11:54 GMT
Reason for closing:  No response
Comment by Dan Griffiths (Ghost1227) - Friday, 26 February 2010, 21:22 GMT
I would recommend adding provides=('proxy-server') to all proxy servers in the official repos, then making dansguardian depend on proxy-server. Will bring it up on ML
Comment by Florian Pritz (bluewind) - Saturday, 03 July 2010, 18:55 GMT
status?
Comment by Jelle van der Waa (jelly) - Saturday, 14 January 2012, 19:23 GMT
again status?

Loading...