Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18119 - [util-linux-ng] 2.17-1 - HAL issues, automount stops working, mount gives segmentation fault error

Attached to Project: Arch Linux
Opened by The Great Chaniyth (Chaniyth) - Tuesday, 02 February 2010, 07:46 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 30 April 2010, 06:11 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Description: Segfault for mount for /dev/dvd, /dev/cdrom, /dev/sr0, etc - HAL automount failure.


Additional info:
* package version(s) - util-linux-ng-2.17-1


Steps to reproduce: Insertion of a DVD does not automount, neither do USB stick drives, etc. exec ck-launch-session <window manager> seems to help with the USB issue, but not always nor 100%, however it does NOT fix the CD/DVD automount issue. mount /dev/dvd /media/dvd, mount /dev/cdrom /media/cd, mount /dev/sr0 /media/cd, etc all result in mount giving a Segmentation fault error. Error occurs on ALL my computers, including i686, and x86_64 architectures.

Had to force downgrade package to util-linux-ng-2.16.2-1 until, util-linux-ng-2.17-1 is fixed, or a permanate solution it set in motion.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 30 April 2010, 06:11 GMT
Reason for closing:  Fixed
Comment by The Great Chaniyth (Chaniyth) - Tuesday, 02 February 2010, 07:55 GMT
This problem is NOT just relate to DVD's only, it affects all optical disc types.
Comment by Thomas Ba (thomasba) - Friday, 05 February 2010, 08:11 GMT
It also affects my Surf-stick (Huawai 161).
Comment by Matthias Sobczyk (matzo) - Saturday, 06 February 2010, 20:48 GMT Comment by Dmitry Gavrikov (dmitry923) - Tuesday, 09 February 2010, 18:38 GMT
I experience the same bug with my desktop and downgrading to util-linux-ng-2.16.2-1 helped. Strangely though I have a notebook with almost the same packages (x86_64 distro, KDE4mod and both desktop and notebook distros are up-to-date) and it is not affected by this bug. Maybe the bug is hardware related? So if you need me to do some tests both on the affected and the unaffected computers to help close this bug I will be glad to help.
Comment by Kai Hendry (hendry) - Tuesday, 09 February 2010, 23:07 GMT
Where did you find the package to downgrade?
Comment by The Great Chaniyth (Chaniyth) - Tuesday, 09 February 2010, 23:12 GMT
@Kai Hendry

You get it from the ARM repositories.

Here is the Arch Linux WIKI page on it. http://wiki.archlinux.org/index.php/Downgrading_Packages
Comment by Kai Hendry (hendry) - Tuesday, 09 February 2010, 23:31 GMT
@Chaniyth Thank you. Rolling back helped me get on with a ddrescue task of a CD.
Comment by Jürgen Hagemann (cappucco) - Saturday, 13 February 2010, 03:14 GMT
Please fix this... Two of my machines are affected of this bug. I cannot read any CD or DVD there.
Comment by Jürgen Hagemann (cappucco) - Tuesday, 16 February 2010, 13:52 GMT
I confirm, that after downgrading to util-linux-ng-2.16.2-1, the problems are gone. I wonder, that there are not more people affected by this bug. This bug is also discussed here: http://bugs.gentoo.org/show_bug.cgi?id=301787
The annexed patch from Matthias Sobczyk seems to be the right solution...
Comment by Anton (Gerenuk) - Tuesday, 16 February 2010, 22:12 GMT
I have to same problem and just noticed that original CDs (probably made by Windows) work fine.
Comment by Jürgen Hagemann (cappucco) - Thursday, 18 February 2010, 07:19 GMT
Upstream Update is out...
Comment by Tobias Powalowski (tpowa) - Thursday, 18 February 2010, 19:37 GMT
no it isnt' no source available of latest 17.1 only rc1
Comment by Jürgen Hagemann (cappucco) - Thursday, 18 February 2010, 22:25 GMT Comment by Thomas Bächler (brain0) - Monday, 01 March 2010, 18:28 GMT
It should be available now.
Comment by Desislav (Insane-Boy) - Wednesday, 03 March 2010, 16:31 GMT
I have the same problem after a recent update, any ideas how to fix the problem?
Comment by Thomas Bächler (brain0) - Wednesday, 03 March 2010, 17:24 GMT
We need to update to 2.17.1, which should be available now as a stable release.
Comment by Desislav (Insane-Boy) - Wednesday, 03 March 2010, 17:39 GMT
However, according to the last minute upgdate I did ,it seems that only the 2.17-1 version is available.
Comment by Tobias Powalowski (tpowa) - Wednesday, 03 March 2010, 20:48 GMT
there is no loop pach availabe, without it it's useless.
Comment by Thomas Bächler (brain0) - Wednesday, 03 March 2010, 21:00 GMT
We should drop loop-aes. It is deprecated, has no chance of ever being merged upstream and is against Arch patching policies.
Comment by Aaron Griffin (phrakture) - Friday, 09 April 2010, 15:48 GMT
Wow, I blew up this bug report. Re-ope opened the bug, but left the re-open request there....
Comment by Jan de Groot (JGC) - Friday, 16 April 2010, 20:29 GMT
The original bugreport was about segfaults in the mount binary, which should be fixed with 2.17.1 and 2.17.2. This bug was reopened, but I don't see any additional information about what is exactly broken here.
Comment by Tobias Powalowski (tpowa) - Thursday, 22 April 2010, 15:28 GMT
closing again?

Loading...