Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18110 - [miro] does really depend on xine-lib?

Attached to Project: Arch Linux
Opened by Giulio Fidente (giulivo) - Monday, 01 February 2010, 19:47 GMT
Last edited by Jan de Groot (JGC) - Thursday, 15 April 2010, 09:34 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Once installed, miro can be configured to use xine OR gstreamer as backend ... but we have xine-lib listed as dependency, wouldn't it be better to have it listed as suggestion instead of forcing users to install xine-lib (and few others) as dependency even if not used?

Additional info:
* package version(s) - 2.5.4-2
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 15 April 2010, 09:34 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Not a bug anymore: miro has been updated to 3.0, there's no xine backend there anymore.
Comment by Ronald van Haren (pressh) - Monday, 01 February 2010, 20:07 GMT
no I don't think it makes sense because optdepends is for additional functionality, not for core functionality which IMO playback really is. Either way if I'm not mistaken the xine backend will be removed from miro when subtitle support lands (probably in 2.6) so in the future there will be a dependency on gstreamer if that happens.
Comment by Giulio Fidente (giulivo) - Monday, 01 February 2010, 22:23 GMT
I agree with you that playback is a core functionality, but gstreamer delivers it and in fact the package depends on gstreamer0.10-good too ... so what's the point of having two different backends listed as dependecy if you only need one?
Comment by Ronald van Haren (pressh) - Monday, 01 February 2010, 22:40 GMT
The minimal gstreamer dependencies were added for  FS#14684  , not sure if it is still the case but I presume it is as it is just one minor release ago.
Comment by Giulio Fidente (giulivo) - Monday, 01 February 2010, 22:49 GMT
It is still the case, gstreamer is currently the default backend for miro and now we correctly have it included in the dependencies; that's why I'm asking why we need xine-lib too.

As per  FS#14684  you had gstreamer in the optional packages, while it is the default, I'm just wondering why we don't move xine-lib in the optionals, considering that it is not needed to run miro (nor to have playback functionalities that gstreamer delivers)
Comment by Ronald van Haren (pressh) - Monday, 01 February 2010, 22:58 GMT
The listed gstreamer deps are not enough to have playback, it needs some more codecs. Initially the xine backend was chosen because of instability of the gstreamer one, and because of the smaller total size of depencies. This may have changed, I don't know. Could you back it up in numbers for a minimal wm?
Comment by Giulio Fidente (giulivo) - Monday, 01 February 2010, 23:22 GMT
On a clean installation, without X, xine-lib only asks for 51 dependencies.

gstreamer0.10-good-plugins 97
+ gstreamer0.10-ugly-plugins 108
+ gstreamer0.10-bad-plugins 150

In terms of dependencies, xine-lib is more feasible than the gst framework ... but Miro depends on GNOME, which in turns would install a lot of those gstreamer dependencies; unfortunately I don't have any clean GNOME installation to check how much those numbers would change, I'm just assuming that a GNOME user will probably have gstreamer0.10-good-plugins already installed, but this is just _my_ (and possibly wrong) assumption.

The last option which would avoid to people using gstreamer to install xine-lib (and its dependencies) is to have them both listed as optionals but that would break somewhat a "core functionality", unless the user choose and install manually one or another backend.

I would still personally prefer to have gstreamer plugins in by default and xine-lib as opt, but at this point that's only my opinion.

Thanks for listening anyway.
Comment by mattia (nTia89) - Saturday, 06 March 2010, 14:51 GMT
as from official Deps page: https://develop.participatoryculture.org/trac/democracy/wiki/LinuxBuildDocs
and xine-lib OR xine-ui is not listed

Loading...