Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18064 - [elinks] gzip websites not work with latest zlib

Attached to Project: Arch Linux
Opened by Thomas Lucke (Lucky) - Friday, 29 January 2010, 18:40 GMT
Last edited by Pierre Schmitz (Pierre) - Friday, 05 March 2010, 18:04 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Pierre Schmitz (Pierre)
Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
If you go to a website with gzip compression, elinks will not display the site.

Additional info:
elinks 0.11.7-1

not works with
zlib 1.2.3.7-2
zlib 1.2.3.7-1

but works with
zlib-1.2.3.4-4

Steps to reproduce:
Open elinks and go to imdb.org, you see nothing. Only zlib version before 1.2.3.7-1 will work.
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Friday, 05 March 2010, 18:04 GMT
Reason for closing:  Upstream
Additional comments about closing:  will be fixed in next elinks version; disabling zlib support should do it for now.
Comment by Pierre Schmitz (Pierre) - Friday, 29 January 2010, 20:37 GMT
Hint: This seems to be fixed in at least the latest git snapshot of elinks. So probably no zlib bug.
Comment by Pierre Schmitz (Pierre) - Friday, 29 January 2010, 22:09 GMT
elinks-0.12pre5 works fine.
Comment by Thomas Lucke (Lucky) - Saturday, 30 January 2010, 00:06 GMT
Yes, its an elinks bug. No problems with elinks-git.
Comment by Pierre Schmitz (Pierre) - Saturday, 30 January 2010, 02:02 GMT
No, we don't know if it's an elinks bug or zlib.
Comment by Pierre Schmitz (Pierre) - Saturday, 30 January 2010, 02:41 GMT
Another workaround is compiling without zlib support. That shouldn't break anything.
Comment by Thomas Lucke (Lucky) - Saturday, 30 January 2010, 02:55 GMT
Ok, but tests with links/links-g has no problems with any version of zlib.
Comment by Pierre Schmitz (Pierre) - Monday, 01 February 2010, 20:19 GMT
I disabled zlib as a workaround for now to at least have a wroking elinks.

Loading...