Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18061 - [wireshark] packet capture trouble with latest zlib

Attached to Project: Arch Linux
Opened by Mike (Marchael) - Friday, 29 January 2010, 14:49 GMT
Last edited by Ionut Biru (wonder) - Monday, 15 February 2010, 14:35 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Pierre Schmitz (Pierre)
Ionut Biru (wonder)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
After pacman -Syu and running wireshark as root and сhoosing interface, i recieved several packets then capture stoped with error:
"An error ocurred while reading from the file "/tmp/wiresharkXXXXXXGsxKom":Less data was read than expected"

Additional info:
wireshark wireshark-1.2.6-1-i686
log in attached file

Steps to reproduce:
pacman -S wireshark; wireshark
This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 15 February 2010, 14:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  wireshark-1.2.6-2
Comment by Mike (Marchael) - Friday, 29 January 2010, 14:51 GMT
Sorry, I forgot a log :)
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 29 January 2010, 14:53 GMT
  • Field changed: Summary (Wireshark packet capture trouble → [wireshark] packet capture trouble)
  • Field changed: Status (Unconfirmed → Assigned)
  • Task assigned to Ionut Biru (wonder)
Assigned to the latest packager.
Comment by Ionut Biru (wonder) - Friday, 29 January 2010, 14:57 GMT
report it upstream and paste here the link, since i don't think is a packaging bug.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 29 January 2010, 15:00 GMT
I am absolutely not sure here but, can you try downgrading to the old zlib, there are few issues reported. Otherwise as Wonder says, please report to upstream. Thanks.
Comment by Mike (Marchael) - Friday, 29 January 2010, 15:03 GMT
I'm downgradoing to zlib-1.2.3.4-4-i686. And wireshark work nice for now.
Comment by Ionut Biru (wonder) - Friday, 29 January 2010, 15:07 GMT
yep. i think that is a bug in zlib or maybe wireshark is not compatible with this version.
Comment by Gerardo Exequiel Pozzi (djgera) - Friday, 29 January 2010, 15:12 GMT
  • Field changed: Summary ([wireshark] packet capture trouble → [zlib] wireshark packet capture trouble)
  • Task reassigned to Pierre Schmitz (Pierre)
OK, another zlib issue.
Comment by Ionut Biru (wonder) - Friday, 29 January 2010, 15:12 GMT
pierre, seems is a problem with zlib 1.2.3.7-2. i'll try rebuilding to see if is fixing this bug
Comment by Pierre Schmitz (Pierre) - Friday, 29 January 2010, 15:19 GMT
Oh great. Btw: it might be a wireshark bug though. But I guess only the upstream authors might answer this.
Comment by Mike (Marchael) - Friday, 29 January 2010, 16:02 GMT Comment by Andrew S. Grigorev (eigrad) - Friday, 29 January 2010, 16:06 GMT
seems like zlib 1.2.3.7-2 does NOT fix that bug...
Comment by Ionut Biru (wonder) - Friday, 29 January 2010, 16:08 GMT
@Mike a better bug report you couldn't write? :(
Comment by Mike (Marchael) - Friday, 29 January 2010, 16:19 GMT
How can i improve it?
Comment by Matt Keeler (Keeler) - Friday, 29 January 2010, 16:20 GMT
Confirmed bug in zlib. I downgraded and it fixed my wireshark troubles as well.
Comment by Andrew S. Grigorev (eigrad) - Friday, 29 January 2010, 16:30 GMT
wireshark doesn't depend itself by zlib... may be it's gnutls bug?
Comment by Ionut Biru (wonder) - Friday, 29 January 2010, 16:31 GMT
it does use zlib to read compressed data:

--with-zlib[=DIR] use zlib (located in directory DIR, if supplied) to
read compressed data. [default=yes, if available]
Comment by Pierre Schmitz (Pierre) - Friday, 29 January 2010, 16:39 GMT
I assume this could be somehow similar to the issue elinks has. I have sent an email to zlib-devel which all information I have; which is not that much atm. This is a little harder to debug because it does not crash. ;-)
Comment by Pierre Schmitz (Pierre) - Saturday, 30 January 2010, 02:04 GMT
I would appreciate it if someone with more wireshark foo would look into it. It does a lot of weird stuff here like blocking my mouse etc. that cannot be explained by just a possible zlib issue.
Comment by Dale Blount (dale) - Monday, 01 February 2010, 19:18 GMT
It appears upstream has closed the bug as INVALID.
Comment by Alessandro Nakamuta (alessandro_ufms) - Monday, 15 February 2010, 02:30 GMT
I confirm this bug. Same happens here. Downgrading zlib solve the problem.
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 15 February 2010, 04:31 GMT
status with latest zlib-1.2.3.8-1 in [testing]?
Comment by Pierre Schmitz (Pierre) - Monday, 15 February 2010, 06:52 GMT
We'll have to wait until the wireshark devs (or someoje else) has looked into this. I'd recommend to recompile wireshark without zlib support for now. (And because wireshark is unmaintained atm. I'll do that.)
Comment by Ionut Biru (wonder) - Monday, 15 February 2010, 14:35 GMT
wireshark-1.2.6-2 works fine now

Loading...