Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18044 - [file] has wrong md5sum and let rkhunter create a wrong message

Attached to Project: Arch Linux
Opened by Attila (attila) - Wednesday, 27 January 2010, 20:38 GMT
Last edited by Allan McRae (Allan) - Thursday, 28 January 2010, 04:57 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Since the update of file i get this message:

Warning: The command '/usr/bin/rkhunter' has been replaced and is not a script: /usr/bin/rkhunter: a /bin/sh script text executable

In the mailing list of rhunter there is a thread about it and the reason for it is the file command. One gentoo user use the same version of file as archlinux who has this message not and than i give it a try change a copy of the PKGBUILD but i use some thing from the specfile of opensuse. After this all works as before but i can't say if it is the archiv what is wrong (md5sum differs) or the another way to create it.

Additional info:
* file 5.04-1

Steps to reproduce:
- install rkhunter and do this:
# file /usr/bin/rkhunter
/usr/bin/rkhunter: a /bin/sh script text executable
- Optional for the maintainer: Proof why the md5sums differs
- Change the build inside of the PKGBUILD to this:
build() {
cd ${srcdir}/$pkgname-$pkgver || return 1

# opensuse part 1
rm -f Magdir/*,v Magdir/*~
rm -f ltcf-c.sh ltconfig ltmain.sh
autoreconf -fiv || return 1

sed -i 's#\$(datadir)/misc#\$(datadir)#' configure

# opensuse part 2
./configure --prefix=/usr --datadir=/usr/share/file \
--disable-static --with-pic --enable-fsect-man5 || return 1

make || return 1
make DESTDIR=${pkgdir} install
install -d -m 0755 ${pkgdir}/usr/share/misc || return 1
ln -s ../file/magic.mgc ${pkgdir}/usr/share/misc || return 1

install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
}
- run the same command as at the beginning:
# file /usr/bin/rkhunter
/usr/bin/rkhunter: POSIX shell script text executable
This task depends upon

Closed by  Allan McRae (Allan)
Thursday, 28 January 2010, 04:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  file 5.04-2 in [testing]
Comment by Allan McRae (Allan) - Thursday, 28 January 2010, 01:38 GMT
Stupid %*&! upstream... They released a bug fix without changing the version.

Loading...