Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18043 - [e2fsprogs] both e2fsprogs and heimdal provides lib com_err

Attached to Project: Arch Linux
Opened by Natanael Copa (ncopa) - Wednesday, 27 January 2010, 20:24 GMT
Last edited by Ronald van Haren (pressh) - Monday, 22 February 2010, 16:22 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Ronald van Haren (pressh)
Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
heimdal-1.3.1 needs and checks for com_right_r() which is not provided by the e2fsprogs com_err. Since its not detected by the configure script it decides to build its own version of libcom_err.so.

Additional info:
Attatched patch is for e2fsprogs and makes heimdal use the e2fsprogs com_err instead of the heimdal provided one.

I needed append -lpthread to the cf/check-compile-et.m4 when compiled against uclibc. I dont think thats needed for glibc.



Steps to reproduce:
This task depends upon

Closed by  Ronald van Haren (pressh)
Monday, 22 February 2010, 16:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  e2fsprogs 1.41.10-1
heimdal 1.3.1-3
Comment by Allan McRae (Allan) - Thursday, 28 January 2010, 04:51 GMT
Thanks for the patch. I had noticed this the other day and was going to look into it at some stage.

Can you submit the patch upstream? I would prefer them to give it the all OK before we use it.
Comment by Ronald van Haren (pressh) - Friday, 12 February 2010, 13:16 GMT
so e2fsprogs 1.4.10 was released last wednesday without the patch. did you bother sending the patch upstream or did they just reject it?
Comment by Natanael Copa (ncopa) - Friday, 12 February 2010, 14:21 GMT
not submitted. sorry.

i have been busy and this week i have been sick.

Comment by Natanael Copa (ncopa) - Friday, 12 February 2010, 14:33 GMT Comment by Allan McRae (Allan) - Saturday, 20 February 2010, 16:52 GMT
@Ronald: I have looked into this in detail. The patch will likely be accepted by upstream in some form as they have previously implemented functions for heimdal com_err compatibility. This patch comes almost directly from the heimdal code and will only be exposed to programs that use that function (only heimdal at the moment) so is very, very low risk.

I suggested using it for the e2fsprogs-1.4.10 build. Once you do, I will rebuild heimdal against it.
Comment by Ronald van Haren (pressh) - Monday, 22 February 2010, 10:00 GMT
seems fine. Let me see if I can fix the patch, it brakes the compilation of the shared libs.
Comment by Allan McRae (Allan) - Monday, 22 February 2010, 10:09 GMT
OK. Give me a yell if you want me to take a look.
Comment by Allan McRae (Allan) - Monday, 22 February 2010, 15:03 GMT
Replacing strlcpy with strncpy in the patch does the job. Then you need to add additional safety...

Attached is the working patch.
Comment by Ronald van Haren (pressh) - Monday, 22 February 2010, 15:19 GMT
I was just waiting for you to come online to ask about the safety of the strncpy fix... well I have my answer without even asking... it was unsafe but the fix is easy :-) thanks

applying your patch now.

Loading...