Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18042 - [zlib] php->gzopen triggers a segfault

Attached to Project: Arch Linux
Opened by Pierre Schmitz (Pierre) - Wednesday, 27 January 2010, 19:23 GMT
Last edited by Pierre Schmitz (Pierre) - Thursday, 28 January 2010, 12:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity High
Priority High
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since zlib-1.2.3.5 php->gzopen segfaults. I am attaching a test script and the resulting backtrace.

EDIT: This issue was caused by a missing line of code in zlib. Patch attached for completeness. Fixed in version 1.2.3.7-2.
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Thursday, 28 January 2010, 12:28 GMT
Reason for closing:  Fixed

Loading...