Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#18011 - [wicd] fails when reconnects to a network

Attached to Project: Arch Linux
Opened by Jose Valecillos (jvalecillos) - Tuesday, 26 January 2010, 04:25 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 14 April 2010, 09:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:

Since Kernel 2.32.2 Wicd fails to reconnects to a network if you previously have been disconnected from another or the same. No matter what version you use, can be 1.6.* or the new 1.7.0.


Additional info:
* Wicd 1.6.* to 1.7.0
* Since Kernel 2.32.2 and forward

There is a workaround (rough-and-ready) if you reload the kernel module of the wireless interface with rmmod (or modprobe -r, it's the same) and then modprobe. For example, if you have a Atheros card:

modprobe -r ath5k

modprobe ath5k



Steps to reproduce:

The problem is easily reproducible:
You connect to a network, then disconnect, and finally, try to connecting again. Wicd just say: "Unable to obtain IP Address"
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 14 April 2010, 09:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  kernel 2.6.33
Comment by Jose Valecillos (jvalecillos) - Tuesday, 26 January 2010, 04:40 GMT Comment by Isenmann Daniel (ise) - Tuesday, 26 January 2010, 12:14 GMT
Is your behaviour same as this: http://bugs.archlinux.org/task/16138 ?
If yes, this report is a duplicate and the problem is more related to the atheros drivers and not to wicd as you already mentioned in your description.
Comment by Tiago Teixeira (TigTex) - Tuesday, 26 January 2010, 16:42 GMT
I also have this with INTEL drivers (intel wifi 5100)
Comment by Frederic Bezies (fredbezies) - Tuesday, 26 January 2010, 17:16 GMT
duplicate of  bug 18015  if you have testing repository enabled ?
Comment by Frederic Bezies (fredbezies) - Tuesday, 26 January 2010, 17:17 GMT
Oups, wrong bug. I meant  bug 18018 .

With dhcpcd-5.1.4-1 : no working connexion and here is what I get in wicd.log :

2010/01/26 17:21:06 :: dhcpcd: wlan0: broadcasting for a lease
2010/01/26 17:21:06 ::
2010/01/26 17:21:08 :: dhcpcd: wlan0: offered 192.168.1.15 from 192.168.1.1
2010/01/26 17:21:08 ::
2010/01/26 17:21:36 :: dhcpcd: timed out
2010/01/26 17:21:36 ::
2010/01/26 17:21:36 :: DHCP connection failed
2010/01/26 17:21:36 :: exiting connection thread
2010/01/26 17:21:40 :: Sending connection attempt result dhcp_failed
2010/01/26 17:21:45 :: Sending connection attempt result dhcp_failed

With dhcpcd-5.1.3-1 : all is working back !
Comment by Jose Valecillos (jvalecillos) - Friday, 29 January 2010, 23:04 GMT
No, isn't same that  FS#16138  because you can list any avaible network. This problem is diferent, is a reconnection problem. On the other hand, in the comments for  FS#16138  bug, many people seems to have THIS bug really.

I don't now if is related with  FS#18018 , But I've hear of that with other networks managers haven't any problem.

Comment by Isenmann Daniel (ise) - Saturday, 30 January 2010, 10:48 GMT
Ok, what is the status of this bug. I don't think that this is related to wicd. Even the wicd developers have described the bug as "Invalid" on their bugtracker. Can YOU reconnect with other networkmanager or manually? That you heard it, isn't really helping on this.
Comment by Tiago Teixeira (TigTex) - Saturday, 30 January 2010, 14:51 GMT
This is not a wicd problem. Iwconfig, ifconfig and dhcpcd fails with me.
Comment by Isenmann Daniel (ise) - Saturday, 30 January 2010, 17:37 GMT
So this is maybe a dhcpd or kernel problem. I will close this bug, because it isn't a wicd problem.
Comment by Jose Valecillos (jvalecillos) - Sunday, 31 January 2010, 00:49 GMT
I tried with networkmanager and i haven't any problem. I can connect, disconnect and connect again with networkmanager.
Comment by Jose Valecillos (jvalecillos) - Sunday, 31 January 2010, 00:55 GMT
PS: Why you say that wicd developes marked this bug as Invalid?, in wicd bugtracker there's no such bug, i even tried to report it but in the bug form, it need a item that i could not write.
Comment by Isenmann Daniel (ise) - Sunday, 31 January 2010, 09:23 GMT
@Jose: Look at your own link in your first post. The last comment of the devs.
Comment by Jose Valecillos (jvalecillos) - Sunday, 31 January 2010, 13:34 GMT
I understand, But I meant exactly that this bug was not mentioned, just had a bug that apparently related to the comment because it seems similar. Well, if the problem is only with kernels higher than 2.32.2 and has only wicd problem (as far i know and i can check untill now), how is expect it being the way to be to be reported?

Then It should be reported as a kernel bug?
Comment by Daniel Campbell (xelados) - Tuesday, 02 February 2010, 12:23 GMT
I have the same issue. On boot, wicd reports "wlan0: No private ioctls". When I load wicd-client (or wicd-curses), I can connect to a network just fine. Upon disconnecting and attempting to reconnect to any network, it doesn't work. This is a Samsung NC10, by the way.

I can fetch more information if needed.
Comment by Isenmann Daniel (ise) - Tuesday, 02 February 2010, 12:31 GMT
Are you all using DHCP for getting IP or do you use static IP? With static IP everything is fine.
And if you use DHCP what DHCP program are you using, dhcpd or dhclient?

Maybe there is some misconfigure of the dhcp client you are using.
Comment by Isenmann Daniel (ise) - Tuesday, 02 February 2010, 13:05 GMT
Is the problem you all reporting maybe this one:  FS#17838 

As I said in previous posts I don't know why this should only be related to wicd, because wicd only calls the dhcp client you configure.
Comment by Daniel Campbell (xelados) - Wednesday, 03 February 2010, 00:45 GMT
I use dhcpcd with wicd.

This issue is somewhat confusing. Is there anything I can do to help?
Comment by Isenmann Daniel (ise) - Wednesday, 03 February 2010, 06:13 GMT
@xelados: Can you please install the latest dhclient and try wicd with that? If this is working, then it's not a wicd problem.
Comment by Krishnan (kgas) - Thursday, 11 February 2010, 18:49 GMT
Now wicd is working fine. I had the problem only with wireless.
Comment by Isenmann Daniel (ise) - Sunday, 21 February 2010, 13:06 GMT
So, this is fixed?
Comment by Isenmann Daniel (ise) - Thursday, 04 March 2010, 10:04 GMT
This bug will be closed as fixewd, if no more information is given.
Comment by Marcello Maggioni (Kariddi) - Thursday, 04 March 2010, 21:36 GMT
I still have the problem on my ASUS EEEPC 1000HE.

The only way to reconnect the wlan interface is killing all the wpa_supplicant instances left by wicd and running manually the connection.

I use a WEP connection, and wicd seems to use wpa_supplicant also for WEP protected networks.
Comment by TImothy Feucht (iMothyF) - Tuesday, 13 April 2010, 18:37 GMT
Fixed in Linux 2.6.33

Loading...