Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#17965 - [nautilus] Places displays links to (ntfs)partitions twice with entries in fstab using 'LABEL=NAME'

Attached to Project: Arch Linux
Opened by Tom (hungerfish) - Friday, 22 January 2010, 19:57 GMT
Last edited by Ionut Biru (wonder) - Tuesday, 15 May 2012, 13:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


The Nautilus Places bar displays links to a (ntfs)partition twice when it is mounted via fstab with the LABEL option:

LABEL=WINDOWS /media/WINDOWS ntfs-3g users,exec,locale=en_US.utf8,fmask=133,dmask=022,uid=1000,gid=1000 0 0

One link is the mounted fs, the other when clicked displays an error:
"Unprivileged user can not mount NTFS block devices..."

Using /dev/sdX gives only one link.
Removing the entry altogether in fstab also only displays one link, which when clicked mounts the partition after asking for root pw.

I'm not sure if this only effects ntfs-partitions, which could be likely due to the nature of permission handling there.
Also, this could be upstream, or an udev-rules problem.

Additional info:
* extra/nautilus - 2.28.4-1

Steps to reproduce:
1. Assign a label to a (ntfs)partition. See:
2. Mount it over /media using fstab like above example
3. Should see duplicate link in nautilus places.
4. Revert by using /dev/sdX naming scheme.
This task depends upon

Closed by  Ionut Biru (wonder)
Tuesday, 15 May 2012, 13:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.4.2
Comment by Roman Kyrylych (Romashka) - Tuesday, 10 August 2010, 08:07 GMT
is it still an issue?
Comment by Tom (hungerfish) - Tuesday, 10 August 2010, 10:29 GMT
I'd forgotten about this, but I've just tried it again, and I'm getting the exact same behaviour.

So, yes.
Comment by Ionut Biru (wonder) - Tuesday, 10 August 2010, 10:52 GMT
duplicates are there because you used statically mount and along with automatically mounting feature from nautilus+udisks.

i don't know how upstream does think about it but i guess udisks should ignore statically entries.
Comment by Tom (hungerfish) - Tuesday, 10 August 2010, 11:33 GMT
As I thought, anyway, it shouldn't happen :)
Comment by Greg (dolby) - Friday, 04 March 2011, 05:32 GMT
How DOES upstream feel about this? :)
Comment by Rene (hit) - Monday, 06 June 2011, 07:02 GMT
Still happens here when using other scheme than /dev/sdX.
Comment by Allan McRae (Allan) - Saturday, 28 April 2012, 14:36 GMT
Comment by Tom (hungerfish) - Tuesday, 15 May 2012, 12:19 GMT
Using nautilus 3.4.1 this issue no longer exists. When mounted below /media partitions are listed in the 'places bar' as expected. (They don't show when mounted below /mnt)
Thunar and also Dolphin also behave as expected.