Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17902 - HAL usage breaks keyboard in X

Attached to Project: Arch Linux
Opened by Hubert depesz Lubaczewski (depesz) - Tuesday, 19 January 2010, 11:59 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 19 January 2010, 17:30 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After recent upgrade, Xorg stopped to run if hal is not running. OK. So I started HAL. the problem is that it completely breaks keyboard - pressing any arrow key, or windows key generates extra, keypresses - like "ENTER", or some letters.

examples - arrow down, generates arrow down and then enter. windows key generates letter "F" and then windows key code.

I do not know how to debug it more. Is there any known problem regarging it?

Additional info:
* hal - 0.5.14-1
* xorg - newest, today upgraded
* kde 4.3

I use logitech wireless keyboard - which works OK without HAL.
Keyboard is configured as pc105 with layout pl and variant pl.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 19 January 2010, 17:30 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Configuration error.
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 19 January 2010, 13:13 GMT
  • Field changed: Status (Unconfirmed → Waiting on Response)
  • Task assigned to Jan de Groot (JGC)
I guess that HAL is not the problem but xf86-input-evdev. HAL will report "evdev" as the driver for you keyboard, the X use it. Try to load evdev when you run X without HAL.
Comment by Jan de Groot (JGC) - Tuesday, 19 January 2010, 13:19 GMT
Can you attach Xorg.0.log and xorg.conf?
Comment by Hubert depesz Lubaczewski (depesz) - Tuesday, 19 January 2010, 14:37 GMT
Please find attached files.

More background information - after filling the bug, I removed hotplug from xorg.conf (commented out it now), and removed hal from rc.conf.

It worked ok - all keys fine.

Now, when I turned hal back on, and autoplug - I have still keyboard issues, but different?! windows key works ok now - no extra chars.

But. Right alt generates "enter" and it generates something which makes it not possible to enter my accented letters (polish) - which usually are generated using right-alt + letter - np. ą is right-alt + a now it simply makes enter (new line), and that's all.
Comment by Jan de Groot (JGC) - Tuesday, 19 January 2010, 14:55 GMT
By specifying the AllowEmptyInput False option, and not disabling hal, your keyboard devices will get added twice: once by configuration, and once by hal. This causes weird things, as both don't lock the device but just grab the keycodes they can get.
Comment by Hubert depesz Lubaczewski (depesz) - Tuesday, 19 January 2010, 16:16 GMT
Thank you. It solved the problem. Sorry for invalid bug report.

Loading...