Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#17874 - [pacman] bash completion with nonstandard DBPath

Attached to Project: Pacman
Opened by Matthias Sobczyk (matzo) - Sunday, 17 January 2010, 13:54 GMT
Last edited by Allan McRae (Allan) - Friday, 19 January 2018, 04:27 GMT
Task Type Bug Report
Category Scripts & Tools
Status Closed
Assigned To Andrew Gregory (andrewgregory)
Architecture All
Severity Very Low
Priority Normal
Reported Version 3.3.3
Due in Version 5.1.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:

The file `/etc/bash_completion.d/pacman` does not respect pacman's `DBPath` variable which is defined in `/etc/pacman.conf`.

Since the `DBPath` is freely selectable everything should work as well as with a standard configuration.

One possible implementation is annexed. So far, it works for me.






This task depends upon

Closed by  Allan McRae (Allan)
Friday, 19 January 2018, 04:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  git commit b2e088e42cfb5be
Comment by Dan McGee (toofishes) - Wednesday, 20 January 2010, 04:41 GMT
I'm not super keen on having to grep a system config file, but looking at the completion file I guess we do this already. There are many ways to specify the dbpath including directly on the command line, so shouldn't we use that if it proceeded us hitting tab in the args? That would be one worthy addition.

In addition, if one has a non-standard DB location wouldn't they be just as likely to have a non-standard location config file? Allan, thoughts?
Comment by Allan McRae (Allan) - Wednesday, 20 January 2010, 06:22 GMT
The patch "fixes" (not tested) the issue with DB_PATH so I think it should be pulled. There are already many similar issues if someone is a non-standard config file location so this is not making the situation any worse.
Comment by Allan McRae (Allan) - Sunday, 31 January 2016, 04:30 GMT
This will be addressed with the addition of pacconf.
Comment by Allan McRae (Allan) - Friday, 19 January 2018, 04:27 GMT
Most of the reported issues were obsolete, but the remaining was fixed in git commit b2e088e42cfb5be.

Loading...