Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17837 - [xorg] Xserver display blanks to single color, fixed by suspend and resume

Attached to Project: Arch Linux
Opened by Fred (pseudonomous) - Thursday, 14 January 2010, 18:52 GMT
Last edited by Jan de Groot (JGC) - Monday, 03 October 2011, 14:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The display on my laptop blanks to a single color; often black sometimes white or blue, keyboard input still woks (I presume mouse input works as well, but don't really know), suspending to ram and resuming will bring the display back into a functioning state. There's nothing real interesting the Xorg.0.log, I'll attach a 50 line tail, anyway though, from immediatly after I fix this with a "suspend and resume" by unplugging the power chord, closing and opening the laptop lid.

This has happened while running firefox, vlc, and emacs, but running these apps account for about 75% of my computer usage, with the another 24% being accounted for by Konsole; the system has not yet done this while running Konsole, I suspect coincidence.


Additional info:
* package version(s)

kernel 2.6.32.2-2
xorg-server 1.7.3.902-1
local/xf86-input-evdev 2.3.2-1 (xorg-input-drivers)
local/xf86-video-intel 2.9.1-1 (xorg-video-drivers)
emacs 23.1-1
firefox 3.5.7-1
vlc 1.0.4-1

All Packages:

attached as pkg.list

* config and/or log files etc.

$ tail -n 50 /var/log/Xorg.0.log
(II) config/hal: Adding input device Power Button
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event4"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Video Bus
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event2"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Power Button
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event6"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) intel(0): EDID vendor "AUO", prod id 4305
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1024x576"x0.0 54.40 1024 1072 1104 1470 576 580 584 614 +hsync -vsync (37.0 kHz)
(II) intel(0): EDID vendor "AUO", prod id 4305
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1024x576"x0.0 54.40 1024 1072 1104 1470 576 580 584 614 +hsync -vsync (37.0 kHz)
(II) AIGLX: Suspending AIGLX clients for VT switch
(II) Open ACPI successful (/var/run/acpid.socket)
(II) AIGLX: Resuming AIGLX clients after VT switch
(II) intel(0): No memory allocations
(II) intel(0): EDID vendor "AUO", prod id 4305
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1024x576"x0.0 54.40 1024 1072 1104 1470 576 580 584 614 +hsync -vsync (37.0 kHz)
(--) SynPS/2 Synaptics TouchPad: touchpad found
(II) GASIA PS2toUSB Adapter: Device reopened after 1 attempts.
(II) GASIA PS2toUSB Adapter: Device reopened after 1 attempts.
(II) AT Translated Set 2 keyboard: Device reopened after 1 attempts.
(II) Macintosh mouse button emulation: Device reopened after 1 attempts.
(II) Integrated Webcam: Device reopened after 1 attempts.
(II) Sleep Button: Device reopened after 1 attempts.
(II) Power Button: Device reopened after 1 attempts.
(II) Video Bus: Device reopened after 1 attempts.
(II) Power Button: Device reopened after 1 attempts.

Hardware Info: (from lspci)

00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
03:00.0 Network controller: Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)

Steps to reproduce:

This bug seems intermittent, it shows up a bout once a day, but after it occurs once, it occurs often.
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 03 October 2011, 14:02 GMT
Reason for closing:  No response
Additional comments about closing:  No response for several months, comments indicate this doesn't happen anymore with current packages.
Comment by Alexander Straube (a-st) - Monday, 18 January 2010, 09:47 GMT
Same problem here. :'(

System is a SAMSUNG NC10 Netbook:
---------------------------------
CPU: Intel(R) Atom(TM) CPU N270 @ 1.60GHz
RAM: 1x1024 MB DDR2-533

Package Versions:
-----------------
kernel26-nc10 2.6.33-rc4
xf86-video-intel 2.9.99.902-1
xorg-server 1.7.3.902-1
mesa 7.7-1

lspci Output:
-------------
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
02:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 13)

Comment by Mihail (pevzi) - Monday, 25 January 2010, 06:00 GMT
Turn off KMS by adding i915.modeset=0 to boot options in /boot/grub/menu.lst . That helped me. Seems that it's intel video driver bug.
Comment by Fred (pseudonomous) - Wednesday, 17 February 2010, 23:01 GMT
To state the obvious: disabling KMS is no longer an option, the bug still is present with:

local/intel-dri 7.7-1
Mesa DRI drivers for Intel
local/xf86-video-intel 2.10.0-1 (xorg-video-drivers)
X.org Intel i810/i830/i915/945G/G965+ video drivers

I see, though, that there's a new drm and xserver package, so I guess I'll find soon if the bug is still present
after installing these.
Comment by Fred (pseudonomous) - Friday, 19 February 2010, 02:23 GMT
Nope, bug is still present.
Comment by Greg (dolby) - Friday, 04 March 2011, 05:29 GMT
Is it still a problem? Have you reported upstream?
Comment by Fred (pseudonomous) - Friday, 04 March 2011, 05:35 GMT
Hasn't happened to me for quite sometime, I believe I did report this bug upstream
Comment by Greg (dolby) - Friday, 04 March 2011, 05:50 GMT
Could you provide a link to the report?

Loading...