Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17821 - [kernel26] (2.6.32-*): bug on kernel ACPI

Attached to Project: Arch Linux
Opened by Silenx (Silenx) - Wednesday, 13 January 2010, 12:30 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 14 February 2012, 14:28 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
I found this annoying bug on kernel26 2.6.32-2 and -3
Laptop, ( intel based ) after minutes of use, go crazy with kernel ACPI, so syslog-ng flood every 2 sec the same error message growing up the /var/log/ ( i will attach a file with message ). after this it go a little jerky.
The very problem, with the acpi error ON, is that: when i turn off or reboot i have to put out every alimentation source, like battery and/or AC adaptor, ( like a power current reset ), after laptop go on bios and start, if i don't make this procedure, laptop turn on with black screen, the fan spin for 2 sec and the machine turn off. if i try to restart, he made the same thing, only power-source reset let me start normally my machine
Best Regards


Additional info:
* package version(s) ----> local/kernel26 2.6.32.3-1 (base) ( and before the -32.2 )
* config and/or log files etc.


Steps to reproduce:
   file.log (6.8 KiB)
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 14 February 2012, 14:28 GMT
Reason for closing:  Upstream
Comment by Jan de Groot (JGC) - Wednesday, 13 January 2010, 13:30 GMT
What laptop is this?
Comment by Silenx (Silenx) - Wednesday, 13 January 2010, 13:47 GMT
I posted the lspci in the error log file for the hardware, the brand is Acer, an Acer 5735, same thing on my friend's laptop 5735Z, and another HP Compaq, all intel based
Comment by Silenx (Silenx) - Saturday, 23 January 2010, 11:25 GMT
Same bug on local/kernel26 2.6.32.4-1
Comment by Silenx (Silenx) - Sunday, 24 January 2010, 13:32 GMT
[silenx@cerberus-x ~]$ pacman -Qs kernel26
local/kernel26 2.6.32.5-1 (base)
Same bug today on new 32.5-1

The Linux Kernel and modules
local/kernel26-firmware 2.6.32.5-1 (base)
The included firmware files of the Linux Kernel
local/kernel26-headers 2.6.32.5-1
Header files and scripts for building modules for kernel26

Jan 24 14:29:56 cerberus-x kernel: ACPI Exception: AE_TIME, Returned by Handler for [EmbeddedControl] (20090903/evregion-424)
Jan 24 14:29:56 cerberus-x kernel: ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.AMW0.WMCA] (Node ffff8800bb0183a0), AE_TIME
Jan 24 14:29:58 cerberus-x kernel: ACPI Exception: AE_TIME, Returned by Handler for [EmbeddedControl] (20090903/evregion-424)
Jan 24 14:29:58 cerberus-x kernel: ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.AMW0.WMCA] (Node ffff8800bb0183a0), AE_TIME
Jan 24 14:30:00 cerberus-x kernel: ACPI Exception: AE_TIME, Returned by Handler for [EmbeddedControl] (20090903/evregion-424)
Jan 24 14:30:00 cerberus-x kernel: ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.AMW0.WMCA] (Node ffff8800bb0183a0), AE_TIME
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 24 January 2010, 16:57 GMT
Please report to upstream, this is the only way to solve this type of issues. Thanks.
Similar report (and currently fixed) here: http://bugzilla.kernel.org/show_bug.cgi?id=14247
Comment by pcxz (pcxz) - Tuesday, 02 February 2010, 18:12 GMT
Same identical problem for me in all 2.6.32.{1-7} kernel

Comment by Stéphane Travostino (eazy) - Thursday, 11 February 2010, 09:54 GMT
Seems to be fixed on 2.6.32.8 (on Acer Aspire 5930G, 64bit)
Comment by Gerardo Exequiel Pozzi (djgera) - Thursday, 11 February 2010, 17:59 GMT
  • Field changed: Status (Assigned → Waiting on Response)
@Silenx: Please confirm is fixed on your system with 2.6.32.8. If not, please report to upstream and paste the link here. Thanks.
Comment by Stéphane Travostino (eazy) - Thursday, 11 February 2010, 19:57 GMT
I managed to run the 2.6.32.8 kernel for 10 hours without any glitch, but upon inserting a USB disk I have experienced the issue.

Did not try to reproduce it as I have to remove and reinsert the battery at the next boot, and I don't want to risk to ruin some piece of hardware.

Rolled back to 2.6.31
Comment by Silenx (Silenx) - Thursday, 11 February 2010, 22:28 GMT
Ok Gerardo, i'm updating packages now. i try with this and i'll post.
I have encountered the same problem of eazy but with 32.7, and after a lot of hour like him.
I heard this problem is on a lot of distribution, so is not the distro but the kernel .. same thing on 33-rc5 ( read on some forum post ) ... i wish on 32.8
Comment by Silenx (Silenx) - Thursday, 11 February 2010, 23:29 GMT
Ok, i'll tested .32.8 .. same error, after 10 minutes of use.
Comment by André Felício (antigerme) - Monday, 22 February 2010, 14:35 GMT
I'm having the same problem. Kernel 2.6.32.8-1 with Hp Elitebook 2730p
Comment by pcxz (pcxz) - Saturday, 27 February 2010, 07:10 GMT
This bug, for me, is solved with a patch released in:
http://bugzilla.kernel.org/show_bug.cgi?id=14733

Comment by Knut Tidemann (Avenger) - Saturday, 27 March 2010, 01:59 GMT
I would like to add that I exact issue described here, and it is not fixed in 2.6.33.1 in testing. The issue seems to appear at random, but usually after the compuuter has been on for a day or so. I can add that if I run my laptop on power without the battery plugged in, the error will not appear.

My laptop is an Acer Aspire 5930G which is intel centrino 2 based and is running arch testing x86_64. I will try the patch above and see if it fixes anything.
Comment by Stéphane Travostino (eazy) - Saturday, 27 March 2010, 20:18 GMT
@Avenger: I've got the same PC and I solved with the second patch, https://bugzilla.kernel.org/attachment.cgi?id=25261

I've been using the patched 2.6.32.9 for a month, no more issues with it.
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 03 July 2010, 22:01 GMT
status with latest 2.6.34?
Comment by Knut Tidemann (Avenger) - Sunday, 04 July 2010, 13:03 GMT
I installed 2.6.34-2-x86_64 yesterday and so far I have not noticed this bug. It's been used now for about 5hrs.

As the problem seem to come at somewhat random time intervals I cannot say that it's 100% fixed, but I will report back here in the next few days if I notice anything.
Comment by Stéphane Travostino (eazy) - Tuesday, 10 August 2010, 13:18 GMT
No it is not solved. The kernel bug is still OPEN and I'm running a patched 2.6.34 because the vanilla one is unusable.
Comment by Roman Kyrylych (Romashka) - Tuesday, 10 August 2010, 13:21 GMT
@Tobias, Thomas:
do you think we should apply the patch? (https://bugzilla.kernel.org/attachment.cgi?id=25261)
Comment by Knut Tidemann (Avenger) - Thursday, 26 August 2010, 17:49 GMT
I just wanted to say that this bug is not fixed on my laptop either, it just took alot of time before it appeared again. Running 2.6.35.3 at the moment.
Comment by Carlo Casta (carcass) - Thursday, 26 August 2010, 18:14 GMT
Not fixed yet. Patch in https://bugzilla.kernel.org/attachment.cgi?id=25261 is still needed. I like the idea of applying it to arch kernels. Any chance? The patch is very basic and it's completely harmless for anyone not experiencing this bug.
Comment by Yasin ÖZCAN (zubak) - Monday, 28 February 2011, 14:37 GMT
hi Patch didnt work. i m using acer 5735g. kernel 2.6.37.1-1
Comment by Hans Muster (luz) - Thursday, 14 April 2011, 14:47 GMT
Hi, i use ubuntu 10.04 32bit with the Kernel 2.6.32-30 on the Aspire5930 and got exactly the same Problem.
The bug makes the computer unusable after hours of usage.
Comment by Jelle van der Waa (jelly) - Thursday, 14 April 2011, 21:13 GMT
is this still an issue with the latest kernel?
Hans Muster, please report this bug upstream
Comment by Hans Muster (luz) - Friday, 15 April 2011, 08:18 GMT
I now installed the Kernel 2.6.38-8, rebooted and then run my computer over the night. I had virtualbox with an instance of winxp running on the Linux, because i thought that could have any influence. The bug still exists, as you can see in my attached log-files. Today i'm going to check if the bug also appears without having virtualbox started.

"to report this bug upstream" -> can i post in this topic or do in need a new one? and what logfiles you need?
Comment by Hans Muster (luz) - Saturday, 16 April 2011, 14:34 GMT
Well, the bug does also appear without running virtualbox.
Comment by Jelle van der Waa (jelly) - Tuesday, 24 May 2011, 16:06 GMT
please post the upstream bug report
Comment by Knut Tidemann (Avenger) - Tuesday, 24 May 2011, 16:09 GMT
It has already been posted some posts up:

https://bugzilla.kernel.org/show_bug.cgi?id=14733
Comment by Yasin ÖZCAN (zubak) - Friday, 03 June 2011, 00:04 GMT

Loading...