Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17810 - [udev] Palm devices can't connect to usb as user

Attached to Project: Arch Linux
Opened by jib (jib2) - Tuesday, 12 January 2010, 21:19 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 13 January 2010, 07:52 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: When plugging a Palm Pilot device, ttyUSB0 and ttyUSB1 are created with root:uucp ownership and no rw access for users.
Then the Palm won't sync, unless the user is added to uucp group.

Additional info:
* package version(s): udev-146-2
* config and/or log files etc.

$ ls -l
crw-rw---- 1 root uucp 188, 0 janv. 12 22:15 /dev/ttyUSB0
crw-rw---- 1 root uucp 188, 1 janv. 12 22:15 /dev/ttyUSB1


Steps to reproduce:
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 13 January 2010, 07:52 GMT
Reason for closing:  Not a bug
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 12 January 2010, 23:34 GMT
  • Field changed: Status (Unconfirmed → Waiting on Response)
What is the bug here?. Just adding a user to uucp group in Arch Linux is way to access to serial ports and other devices.

You can't use the audio unless your user is member of audio, you can't use cameras if the user...
Comment by jib (jib2) - Wednesday, 13 January 2010, 06:43 GMT
OK, that's good to know (I had read somewhere that uucp is a system group and shouldn't be used by a user for security reasons).
I'll add this on the Palm wiki page.
Thanks.

Loading...