Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17790 - [zlib] libz.so.1: cannot enable executable stack, with PaX enabled (breaks pacman)

Attached to Project: Arch Linux
Opened by Cristian C. (ckristi) - Monday, 11 January 2010, 10:18 GMT
Last edited by Pierre Schmitz (Pierre) - Sunday, 17 January 2010, 08:27 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
zlib-1.2.3.4-3 requires executable stack. On kernels with PaX enabled or (probably) the NX bit enabled zlib will stop working taking
even pacman after it. This raises another issue, I think there's a need for a pacman.static included in the pacman package, but that is something else.

Additional info:
* zlib-1.2.3.4-3 (on the older zlib-1.2.3.3-x it worked)
* libz.so.1: cannot enable executable stack as shared object requires


Steps to reproduce:
On a runnning kernel with PaX enabled, libz.so exits with the above error
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Sunday, 17 January 2010, 08:27 GMT
Reason for closing:  Implemented
Comment by Pierre Schmitz (Pierre) - Monday, 11 January 2010, 14:28 GMT
Does this package work for you: https://users.archlinux.de/~pierre/tmp/zlib-1.2.3.4-3.1-i686.pkg.tar.gz? This one comes without "handwritten assembler code".
Comment by Cristian C. (ckristi) - Monday, 11 January 2010, 16:21 GMT
Hello.

Unfortunately I couldn't bear the instability generated by this bug (I was also a little angry because of the lack of PAE enabled kernels in the Arch repo) so I switched my home server to another distro. But I'll put up a test machine (clone to my old server system) tonight and I'll let you know. I presume the assembler code generated this bug, because the assembler code was killing openssl libraries, too.

Comment by Cristian C. (ckristi) - Monday, 11 January 2010, 18:43 GMT
Hey, again.
Your package works ok on the PaX enabled kernel.
Comment by Cristian C. (ckristi) - Saturday, 16 January 2010, 08:45 GMT
I'm writing here again only to tell you how dissapointed I am in the resolution of this issue. It's been almost a week now I've posted this bug, Pierre was very helpful in providing a test package to see if it works. I, even if I had disabled my old system with Arch and PaX-enabled kernel, spent some time to revive it from backups and test, and all you do now is to lower the severity of the problem so it doesn't show on the front page? Not even a [testing] package? I am very dissapointed in this distribution and congratulate myself that I switched my homeserver and laptop from Arch. My desktop will follow. If you will continue to grow in popularity (Distrowatch says that you are and at a fast pace) and will not be able to cope with a great variety of users' requests, your distro will have an epic fall. I've talked about this with Jules Pitsker also and by this post I am allowing him to share the e-mails we've sent each other. I am really hoping that my dissapointment and past contribution to this distribution will not go into the void.

Loading...