Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17753 - [ppp] bogus DNS server problem with 3G modems

Attached to Project: Arch Linux
Opened by Luis Miranda (luuuis) - Friday, 08 January 2010, 15:19 GMT
Last edited by Allan McRae (Allan) - Saturday, 02 June 2012, 11:55 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Paul Mattal (paul)
Thomas Bächler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

There is a known problem in core/ppp-2.4.4-9 which

Relevant excerpt from /var/log/messages.log:
"
Jan 8 15:14:09 xxxxxxxx pppd[1037]: pppd 2.4.4 started by root, uid 0
Jan 8 15:14:09 xxxxxxxx pppd[1037]: Using interface ppp0
Jan 8 15:14:09 xxxxxxxx pppd[1037]: Connect: ppp0 <--> /dev/ttyUSB0
Jan 8 15:14:09 xxxxxxxx pppd[1037]: CHAP authentication succeeded
Jan 8 15:14:09 xxxxxxxx pppd[1037]: CHAP authentication succeeded
Jan 8 15:14:09 xxxxxxxx kernel: PPP BSD Compression module registered
Jan 8 15:14:09 xxxxxxxx kernel: PPP Deflate Compression module registered
Jan 8 15:14:49 xxxxxxxx pppd[1037]: Could not determine remote IP address: defaulting to 10.64.64.64
Jan 8 15:14:49 xxxxxxxx pppd[1037]: local IP address 88.210.112.219
Jan 8 15:14:49 xxxxxxxx pppd[1037]: remote IP address 10.64.64.64
Jan 8 15:14:49 xxxxxxxx pppd[1037]: primary DNS address 10.11.12.13
Jan 8 15:14:49 xxxxxxxx pppd[1037]: secondary DNS address 10.11.12.14
"

The patch from Paulius Zaleckas in this thread is reported to solve the problem:

http://marc.info/?l=linux-ppp&m=121491316432652&w=2

Direct link to patch:

http://marc.info/?l=linux-ppp&m=121491316432652&q=p3

References:

https://bugzilla.redhat.com/show_bug.cgi?id=467004
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=445711
https://bugs.launchpad.net/ubuntu/+source/ppp/+bug/258801
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 02 June 2012, 11:55 GMT
Reason for closing:  No response
Comment by Thomas Bächler (brain0) - Friday, 08 January 2010, 17:23 GMT
Can you please describe exactly what's wrong here? I don't see the problem from the log.
Comment by Luis Miranda (luuuis) - Friday, 08 January 2010, 17:39 GMT
Sorry, I truncated the bug description by accident.

What's happening is that the addresses for the primary and secondary DNS addresses are bogus, and do not correspond to the addresses handed out by the ISP (10.11.12.13 and 10.11.12.14). Sometimes pppd gets the correct addresses, and other times not (as in the log above).

Apparently this is caused by pppd requesting the info from the 3G modem before they have been handed out by the ISP (for more details see the bugs in the references part of this report).
Comment by Roman Kyrylych (Romashka) - Saturday, 13 February 2010, 16:05 GMT
I do not have this problem with my 3G modem. Looks like it depends on hardware.
Do you use NetworkManager?
Comment by Ray Rashif (schivmeister) - Saturday, 06 March 2010, 19:21 GMT
I'm using a Huawei E220 (3.5G, option) and Motorola ROKR E8 (EDGE, cdc_acm), neither exhibit this problem and I'm getting DNS fine.
Comment by Paul Mattal (paul) - Saturday, 06 March 2010, 21:26 GMT
A cursory walk through gitweb of ppp upstream suggests this is not yet fixed there.

Has anyone submitted this patch upstream? If so, any reason we shouldn't include it?

If not, I'll do that in the next few weeks.
Comment by Thomas Dziedzic (tomd123) - Saturday, 03 July 2010, 20:47 GMT
status?
Comment by Greg (dolby) - Friday, 04 March 2011, 03:37 GMT
https://bugzilla.redhat.com/show_bug.cgi?id=467004#c43 says that the problem is gone.
Plus the Debian bug report marks this af fixed upstream: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=445711#97 not by one of their patches.
Comment by JM (fijam) - Tuesday, 03 May 2011, 13:44 GMT
Please confirm if this bug was fixed in an upstream update.
Comment by roko (roko) - Saturday, 18 June 2011, 18:22 GMT
Luis, do you still have this problem with the latest ppp?

Loading...