Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17743 - Network Manager 0.7.998 blocks every single program launch it Gnome.

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Friday, 08 January 2010, 06:25 GMT
Last edited by Andrea Scarpino (BaSh) - Friday, 08 January 2010, 07:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: After I upgraded Networkmanager, every single try to launch a program failed in gnome. I worked around this problem by installing wicd.

Very weird.

Additional info:

Dépôt : testing
Nom : networkmanager
Version : 0.7.998-1
URL : http://www.gnome.org/projects/NetworkManager/
Licences : GPL
Groupes : --
Fournit : libnetworkmanager=0.7.998


Part of errors.log with networkmanager in it :

Jan 8 07:01:35 fredo-arch NetworkManager: supplicant_interface_acquire: asserti
on `mgr_state == NM_SUPPLICANT_MANAGER_STATE_IDLE' failed
Jan 8 07:01:41 fredo-arch NetworkManager: nm_ip4_config_add_nameserver: asserti
on `nameserver != s' failed
Jan 8 07:04:02 fredo-arch NetworkManager: nm_ip4_config_add_nameserver: assertion `nameserver != s' failed

Steps to reproduce: Just upgrade networkmanager version.


This task depends upon

Closed by  Andrea Scarpino (BaSh)
Friday, 08 January 2010, 07:29 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#17742 
Comment by Frederic Bezies (fredbezies) - Friday, 08 January 2010, 06:27 GMT
Looks like it could be related to policit-kit / polkit transition ?!
Comment by Frederic Bezies (fredbezies) - Friday, 08 January 2010, 06:32 GMT
Downgrading to networkmanager 0.7.2 fixes the bug. Ouch !
Comment by Lex Rivera (x-demon) - Friday, 08 January 2010, 06:57 GMT
this is probably duplicate of bug  FS#17742 
Comment by Frederic Bezies (fredbezies) - Friday, 08 January 2010, 07:27 GMT
It could be. But it is weird to see that a network manager could block everything or nearly everything in gnome.

Loading...