FS#17728 - [openoffice-base-beta] lacking correct dependencies to work over ssh with X11 forwarding

Attached to Project: Arch Linux
Opened by partner55083777 (partner55083777) - Wednesday, 06 January 2010, 22:46 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 15 January 2010, 05:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



I don't think extra/openoffice-base-beta has the correct dependencies. I tried installing OOo on a headless server and using it over ssh with X11 forwarding, but it gives the error:

"no suitable windowing system found, exiting."

I'm not sure exactly what packages or dependencies it needs, so I decided to try to install Firefox, thinking that firefox would probably pull in whatever graphical dependency OpenOffice also needs.

Firefox pulled in these dependencies:
xulrunner- startup-notification-0.10-1 nss-3.12.4-2 nspr-4.8.2-1 mozilla-common-1.4-1 mime-types-1.0-2 libidl2-0.8.13-1 gtk2-2.18.5-1 shared-mime-info-0.70-2 pango-1.26.2-1 libthai-0.1.12-1 libdatrie-0.2.2-1 cairo-1.8.8-1 xcb-util-0.3.6-1 pixman-0.16.4-1 libxrandr-1.3.0-1 randrproto-1.3.1-1 libxinerama-1.1-1 xineramaproto-1.2-1 libxdamage-1.1.2-1 damageproto-1.2.0-1 libxcomposite-0.4.1-1 compositeproto-0.4.1-1 atk-1.28.0-1 alsa-lib-1.0.22-1

OpenOffice then worked perfectly with these additional dependencies pulled in by Firefox.

I'm willing to do some more work to find out which one of these is needed, but I don't know how, other than just testing each package independently. What should I do?

(Using extra/openoffice-base-beta-3.2.0_ooo320_m8-1 and extra/firefox-3.5.7-1)
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 15 January 2010, 05:46 GMT
Reason for closing:  Fixed
Comment by Jan de Groot (JGC) - Wednesday, 06 January 2010, 23:02 GMT
The same is true for openoffice-base and go-openoffice. The base dependencies like gtk2 are covered by its optdepends, so namcap doesn't detect them and the maintainer didn't add them.
Comment by Andreas Radke (AndyRTR) - Thursday, 07 January 2010, 20:07 GMT
gtk2 should be enough. try that. it should pull enough essential deps.
Comment by partner55083777 (partner55083777) - Friday, 08 January 2010, 21:22 GMT
Yes, it works if I install gtk2 first. Thanks!!

Just wondering, would something like this be considered an error with the package, or a PEBKAC on my part?
Comment by Andreas Radke (AndyRTR) - Friday, 15 January 2010, 05:46 GMT
fixed in the -beta and -devel pkg. the stable one will get the fix soon when the beta will become the new stable release.