Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17721 - [nfs-utils] mount.nfs: Operation not permitted

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Wednesday, 06 January 2010, 10:37 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 26 January 2011, 20:11 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Aaron Griffin (phrakture)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Mounts stopped working with the newest update (nfs-utils 1.2.1-2) with:
mount.nfs: Operation not permitted

The same mounts worked without any trouble before. They also work if using
for instance a Centos 5.4 against the same NFS server. No configuration on
server or client side has been changed. No funny firewalls or /etc/hosts.*
settings.

Additional errors in the logfile (/var/log/messages):

rpc.statd: Unable to read state from '/var/lib/nfs/state': errno 0 (Success)
sm-notify: Already notifying clients; Exiting!

Steps to reproduce:
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 26 January 2011, 20:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  seems to be fixed according to comments
Comment by Andreas Baumann (andreas_baumann) - Wednesday, 06 January 2010, 15:03 GMT
Actually I think this is a mere documentation issue: the dummy user updates and doesn't
update the /etc/idmapd.conf or reads the NFS4 section in the Arch Wiki and suddenly mount
happens with nfs4 per default.. :-)

I personally don't think, that NFS 4 is stable enough (too many quircks around ACLs,
cooperation with Samba 4, etc.)
Comment by Marco Milch (manalishi) - Thursday, 07 January 2010, 06:02 GMT
After downgrading nfs-utils to version 1.2.0-5, mount.nfs works again.
Comment by Andreas Baumann (andreas_baumann) - Thursday, 07 January 2010, 10:44 GMT
I see two solutions which work fine for me:
a) configure rpc.idmap properly and use NFS4 (client and server)
b) use mount option 'vers=3' and continue to use NFS3 without
changes to the server or other changes to the client but to
set the vers=3 option
Comment by Fernando L. Canizo (ceb) - Thursday, 07 January 2010, 14:37 GMT
I can confirm the problem and b) solution. Since I don't have access to the server I need to use version 3. Can be used from the command line with:

mount.nfs share mount_point -o 'vers=3'

or in /etc/fstab in a line like:

share mount_point nfs vers=3 0 0
Comment by Herman Jongkind (jongkind) - Thursday, 14 January 2010, 20:05 GMT
'vers=3' option does not work for me.
Comment by Pete (tam1138) - Thursday, 05 August 2010, 06:00 GMT
I cannot reproduce this behavior in nfs-utils-1.2.2-3. "mount.nfs server:share mountpoint" works as expected, without complaining, against a FreeBSD machine running NFSv3.
Comment by Tobias Powalowski (tpowa) - Monday, 01 November 2010, 20:05 GMT
still an issue or can we close this?
Comment by Andreas Baumann (andreas_baumann) - Saturday, 06 November 2010, 12:44 GMT
I reinstalled the QNAP with Centos 5.5 with nfs-utils-1.0.9-47.el5_5
and I completly reinstalled archlinux with nfs-utils 1.2.2-3,
I didn't have any problems anymore.

Loading...