FS#17638 - [mesa] Recent mesa/libgl/savage-dri 7.7 upgrade brakes 3d acceleration on S3 chipsets.

Attached to Project: Arch Linux
Opened by John Wolfe (igneous) - Tuesday, 29 December 2009, 14:24 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 31 March 2010, 10:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Ionut Biru (wonder)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No



This recent mesa upgrade seems to break 3d acceleration on savage cards. As far as I can tell, all 3d applications, including mesa utils (glxinfo/glxgears) abort shortly after returning an assertion of: "../common/drirenderbuffer.c:69: driNewRenderbuffer: Assertion `format == 0x1908 || format == 0x8050 || format == 0x8058 || format == 0x81A5 || format == 0x81A6 || format == 0x81A7 || format == 0x8D48' failed"

Additional info:
* package version(s): mesa 7.7-1, libgl 7.7-1, savage-dri 7.7-1, xorg-server

Steps to reproduce:
1. Be fortunate enough to own a piece of hardware with an S3 chipset.
2. pacman -Syyu
3. Attempt to run any application that uses 3d acceleration... voila

I'll be more than happy to provide any additional information if needed.
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 31 March 2010, 10:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 7.7.1.
Comment by John Wolfe (igneous) - Tuesday, 29 December 2009, 14:31 GMT
Here's just a tad bit of real console output. Although it's probably unlikely it will help.
Also I'm attaching my Xorg.0.log, which is a tad bit confusing, as the savage xorg module reports direct rendering is enabled.
Comment by Andreas Radke (AndyRTR) - Tuesday, 29 December 2009, 14:57 GMT
Please try if recompiling the xf86-video-xxx pkg solves it. Your Xorg log looks ok.
Comment by John Wolfe (igneous) - Tuesday, 29 December 2009, 23:13 GMT
Just rebuilt xf86-video-savage using the pkgbuild in the abs... no dice, still the same issue. Also rebuilt mesa with -g in my cflags/cxxflags via the pkgbuild in the abs, and ran a gdb backtrace of glxinfo... Sorry, as this is an incomplete backtrace, I can't really figure out which libraries I'm going to need to rebuild with debugging symbols included. But hopefully it will give someone an idea of where the problem may reside.
   gdb.log (1.9 KiB)
Comment by Daniel Novotny (danielsoft) - Friday, 01 January 2010, 15:21 GMT
the same error happens to me on Matrox (MGA G550 AGP) graphics card.
Comment by Daniel Novotny (danielsoft) - Saturday, 02 January 2010, 19:09 GMT
ltrace(1) output from glxgears
Comment by Martin Booze (affect) - Tuesday, 05 January 2010, 15:24 GMT
Happened to me on my Intel 815 on-board 64mb card. Downgrading both intel-dri and libgl solved the issue.
Comment by Daniel Novotny (danielsoft) - Tuesday, 05 January 2010, 16:24 GMT
martin, downgrading mga-dri and libgl solves this for me too, thanks
Comment by fabio (fabioamd) - Thursday, 07 January 2010, 14:01 GMT
also with my ATI X1900GT

[fabio@abuarch ~]$ LIBGL_DEBUG=verbose glxinfo
name of display: :0.0
libGL: XF86DRIGetClientDriverName: 5.3.0 r300 (screen 0)
libGL: OpenDriver: trying /usr/X11R6/lib64/modules/dri/tls/r300_dri.so
libGL: OpenDriver: trying /usr/X11R6/lib64/modules/dri/r300_dri.so
libGL error: dlopen /usr/X11R6/lib64/modules/dri/r300_dri.so failed (/usr/X11R6/lib64/modules/dri/r300_dri.so: cannot open shared object file: No such file or directory)
libGL error: unable to load driver: r300_dri.so
display: :0 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
Comment by Evan (Evanlec) - Wednesday, 13 January 2010, 07:31 GMT
confirmed this also with my i810 chip, get the same output with glxinfo/glxgears.
Comment by Andrew de Quincey (adq) - Thursday, 14 January 2010, 06:33 GMT
Hi - confirmed with an S3 Inc. VT8375 [ProSavage8 KM266/KL266] -- same output with glxinfo, downgrading to mesa 7.6.1 sorts it.
Comment by L K (rch) - Monday, 08 March 2010, 06:54 GMT
Confirmed with an MGA G400.

Downgrading to libgl 7.6-2 and mga-dri 7.6-2 provides a fix.

VGA compatible controller: Matrox Graphics, Inc. MGA G400/G450 (rev 04)

Comment by Andreas Radke (AndyRTR) - Thursday, 18 March 2010, 18:11 GMT
please check mesa 7.7.1rc1 in testing. maybe we need to recompile the ddx driver for this.
Comment by Väinö Helminen (vah) - Thursday, 25 March 2010, 11:52 GMT
Yes, the libgl and mga-dri in testing does seem to work with Matrox G550.