Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17616 - [kernel26] 2.6.32 eeepc_laptop module does not load

Attached to Project: Arch Linux
Opened by Varun Acharya (ganja_guru) - Sunday, 27 December 2009, 05:03 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 06 June 2010, 07:13 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:
As of 2.6.32, eeepc_laptop kernel module does not load for me. This error is returned:

$ sudo modprobe eeepc_laptop
FATAL: Error inserting eeepc_laptop (/lib/modules/2.6.32-ARCH/kernel/drivers/platform/x86/eeepc-laptop.ko): No such device

Another user has reported this on a EeePC 1000H, I'm using a 1005HA. Here is the original thread:
http://bbs.archlinux.org/viewtopic.php?id=87316

Additional info:
* package version(s): 2.6.32.2-2


This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 06 June 2010, 07:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  .34 kernel
Comment by Alex Matos (alexmatos) - Wednesday, 30 December 2009, 07:18 GMT
I'm also having this issue. My laptop is also an EeePC 1005 HA.
Comment by Antonio (kokoko3k) - Saturday, 02 January 2010, 09:43 GMT
I can confirm this
Comment by Sebastian (fatmike) - Saturday, 02 January 2010, 19:51 GMT
Same for me. EeePC 1000H i686.
Comment by Raphael Scholer (rscholer) - Sunday, 03 January 2010, 00:16 GMT
Same vor me EeePC 1005HA-H, BIOS 1102.
Comment by Andrej Gelenberg (nikel) - Tuesday, 05 January 2010, 15:00 GMT
The cause is, that new _OSI for windows 7 in the 2.6.32 kernel added. The EEE PC ACPI doesn't knew about windows 7. Patch is:
acpi/blacklist: enable OSI(Linux) on newer eeepc
patch from git://git.iksaif.net/acpi4asus.git.

Here is another patch, that fix rfkill-handler too:
http://bugzilla.kernel.org/attachment.cgi?id=24071
The bugreport:
http://bugzilla.kernel.org/show_bug.cgi?id=14570
Comment by Tobias Powalowski (tpowa) - Saturday, 27 February 2010, 15:09 GMT
status on latest .32 and .33?
Comment by Andrej Gelenberg (nikel) - Monday, 01 March 2010, 13:31 GMT
Not there. We schould wait for new WMI-based driver (i have no idea when it will be done). Workaround: add acpi_osi=Linux to boot options.
Comment by Thomas Dziedzic (tomd123) - Saturday, 05 June 2010, 15:17 GMT
upstream has closed this bug.

"shipped in linux-2.6.33-rc5

closed"

decision?

Loading...