Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17590 - [ncurses] doesn't provide ncursesw/* headers

Attached to Project: Arch Linux
Opened by Ionut Biru (wonder) - Wednesday, 23 December 2009, 13:12 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 23 December 2009, 21:14 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
ncurses doesn't provide ncursesw/ncusers.h header but provide the library. trying to fix  FS#17581  i see

configure:29887: checking ncursesw/ncurses.h usability
configure:29904: gcc -c -march=x86-64 -mtune=generic -O2 -pipe -Wall -std=c99 conftest.c >&5
conftest.c:96:30: error: ncursesw/ncurses.h: No such file or directory

configure:29928: checking ncursesw/ncurses.h presence
configure:29943: gcc -E conftest.c
conftest.c:63:30: error: ncursesw/ncurses.h: No such file or directory

Additional info:

ncurses 5.7-2.1

we had this issue in the past  FS#5263  but i can't see why was reverted.

Steps to reproduce:
try to build egk2

This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 23 December 2009, 21:14 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Wednesday, 23 December 2009, 20:11 GMT
Ncurses _only_ provides the wide headers as we want nothing to link against the non-wide versions (see the PKGBUILD). The program you are compiling is wrong to expect them in /usr/include/ncursesw/...

Loading...