Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17472 - [gdm] crashes randomly when the enter key is pressed

Attached to Project: Arch Linux
Opened by Sam H (samjh) - Saturday, 12 December 2009, 07:41 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 10 August 2010, 18:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Description:

The latest update to xorg-server 1.7.3 causes a hard system crash at random times when the ENTER key is pressed on the keyboard, where "hard crash" means complete system lock-up: no HDD activity, frozen screen display, and no apparent reaction to keyboard or mouse inputs, forcing the user to hard-reset the system. Refer to this forum thread: http://bbs.archlinux.org/viewtopic.php?id=86581

This could possibly be related to an older issue with xorg-server 1.7.1 where X crashed and sent users from the Gnome desktop back to GDM upon pressing the ENTER key. See this forum thread: http://bbs.archlinux.org/viewtopic.php?id=84374

The work-around for both the hard crash with 1.7.3 and the older crash with 1.7.1, is to place the GDM daemon as the last item in the DAEMONS list in /etc/rc.conf.


Additional info:
* package version(s): xorg-server 1.7.3-1
* config and/or log files etc.: no errors or suspicious entries in any /var/log/* files.
* this issue appeared immediately after updating xorg-server from 1.7.2 to 1.7.3 using pacman; forced downgrade to 1.7.2 cured the problem.


Steps to reproduce:
1. Install Gnome, GDM, and Xorg.
2. Place GDM in the DAEMONS list in /etc/rc.conf at a location other than the end of the list.
3. Reboot and log-in to Gnome.
4. In any application or terminal, press enter repeatedly until the system crashes (this may take some time).
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 10 August 2010, 18:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  Patch from last comment has been added to gdm package. GDM starts on vt7+ by default now, no matter what order you start it.
Comment by Acegi (Aq32) - Monday, 14 December 2009, 17:24 GMT
Using:
Kernel 2.6.31-ARCH (x86_64)
X.Org X Server 1.7.1.901 (1.7.2 RC 1)

At irregular intervals (actually I haven't timed it) when I am typing some text into any application and then press Enter it will restart X in exactly the same way as pressing Ctrl+Alt+Backspace usually does. This is massively annoying since it's starting to make me paranoid that I will be randomly logged out when I'm in the middle of doing something.
Comment by Gicu Gorodenco (medved) - Wednesday, 16 December 2009, 17:01 GMT
 FS#17525  is related, most probably the same bug, but with another way to reproduce.
Comment by Albert Wesker (NeV3rKilL) - Thursday, 17 December 2009, 10:32 GMT
Here with x64 the same bug. Randomly gnome freezes when enter is pressed.
Comment by Gicu Gorodenco (medved) - Thursday, 17 December 2009, 10:52 GMT
I don't think it's random.
In my case it was freezing after I tried to send a text with ")" in pidgin.
So the sequence of keys was like <text1>)<text2><Enter>
Good that the workaround with placing "gdm" as the last one in daemons list works - I was at the limit to say "fuck-off Arch" because of multiple stupid bugs I'm facing the last few months.
I really love this distro and I don't want to change it, but who knows - 2 years back I was telling the same about Gentoo, which isn't anymore in my life :-)
Comment by Timo Strunk (tstrunk) - Sunday, 20 December 2009, 15:58 GMT
If I'm right, this bug sounds like a dupe of this bug, if gdm starts on term 2:
http://bugs.archlinux.org/task/15881

It was closed with reason: "Won't fix", which was a wrong decision in my opinion. The 'dark' number of users experiencing this issue should be quite big and the existence of this bug is not well known, since everybody thinks about graphics driver errors usually.

Assign to JGC, so he can close it.
Comment by Andrey (Andru) - Wednesday, 23 December 2009, 15:59 GMT
Have the same bug on my desktop ArchLinux i686 and at laptop(HP Pavilion dv6-1225er) x86_64. On laptop - full system freeze, desktop - freeze or sometimes Xorg crash. If I logout after GNOME startup and login again - all work fine.

kernel26: 2.6.31.6-1
xorg-server: 1.7.3.901-1

PS: Sorry for my English.
Comment by Jan de Groot (JGC) - Saturday, 26 December 2009, 15:34 GMT
Please attach Xorg.0.log or Xorg.0.log.old if you're having problems. As stated by Timo, this can be caused by invalid configuration, which is not a bug.
Comment by Andrey (Andru) - Saturday, 26 December 2009, 17:34 GMT
>> Xorg.0.log

There is no errors or something wrong. But moving gdm daemon to last position in list solve my problem. This is very strange workaround :)
Comment by Otto Allmendinger (OttoA) - Tuesday, 23 March 2010, 17:57 GMT
did everything that was suggested, still crashes
Comment by wike (wike) - Tuesday, 13 April 2010, 17:56 GMT
Hi,

I have the same problem. I'm running :
2.6.33-ARCH
xorg-server 1.7.6-3
Nvidia driver 195.36.15-2
KDE 4.4.2-1

   kdm.log (4.3 KiB)
Comment by wike (wike) - Tuesday, 13 April 2010, 20:06 GMT
I disabled loading Virtual Box on the system startup and it solved the problem.
Comment by Otto Allmendinger (OttoA) - Wednesday, 14 April 2010, 22:52 GMT
Putting gdm last in the rc.conf DAEMONS as well as adding the line 0=Standard vt7 both didn't have any effect.

Using the inittab method as described in http://wiki.archlinux.org/index.php/GDM#inittab_method_.28recommended.29 works.

I believe this still is a bug however, because the daemon method should work, and the position of 'gdm' in the DAEMONS array should not matter.
Comment by Erik Mitchell (mitc0185) - Thursday, 10 June 2010, 15:28 GMT
I'm having issues with Xorg crashing as well, and the most recent one was definitely as I hit the Enter key, so I'm going to give this report a bump. I have not tried to repeatedly hit Enter to reproduce.

I did switch from the Daemon method to the Inittab method to start Xorg on my machine this morning. I will see after a few days, I suppose, whether this is an adequate workaround for the problem. I'll post back here whether I have any luck with that.

Attached is my Xorg.0.log file from my crash this morning.
Comment by Julian Pidancet (jpidancet) - Tuesday, 29 June 2010, 18:07 GMT
Please raise the priority of this bug since it is still not fixed nor root-caused, and it seems to affect a significant number of people. Random crashing is IMHO a quite serious issue.

Attached is my xorg.conf and the crash log.

Comment by Jan de Groot (JGC) - Tuesday, 29 June 2010, 19:53 GMT
Your xorg starts on VT2, which is caused by wrong configuration. Fix the way you start gdm and your bug is fixed. This is documented behaviour and is not fixable.
Comment by Otto Allmendinger (OttoA) - Tuesday, 29 June 2010, 20:03 GMT
@JGC: Where - except from this bug report - is it documented that putting GDM in your rc.conf will cause random crashes?

And why is it okay for Xorg to crash when it starts on VT2?
Comment by Jan de Groot (JGC) - Wednesday, 30 June 2010, 06:03 GMT
The gdm bug is documented in the wiki. GDM should be in DAEMONS as last daemon or should be put in inittab to be run in a late runlevel. That way getty can take all the ttys before gdm initializes X. When X initializes on TTY2, it will crash as soon as getty grabs that TTY also.
Comment by Otto Allmendinger (OttoA) - Wednesday, 30 June 2010, 09:46 GMT
As I reported, putting GDM last in the DEAMONS array doesn't always fix the bug, neither does the line "0=Standard vt7" in the gdm config.

The position of gdm in the DEAMONS array shouldn't matter. There are good reasons not for putting gdm at last, and gdm should spawn at vt7 by default.
Comment by Julian Pidancet (jpidancet) - Wednesday, 30 June 2010, 13:51 GMT
There is obviously a race between getty and gdm. Putting GDM last in the DEAMONS array does not fix the bug for me. And using inittab is a workaround, not a proper fix.
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 03 July 2010, 21:51 GMT
  • Field changed: Summary (Xorg or GDM crashes randomly when the enter key is pressed → [gdm] crashes randomly when the enter key is pressed)
  • Field changed: Status (Unconfirmed → Waiting on Response)
  • Task assigned to Jan de Groot (JGC)
so finally this can be closed? Configuration issue that is currently documented at wiki page.
Comment by Otto Allmendinger (OttoA) - Sunday, 04 July 2010, 13:16 GMT
The wiki documentation is wrong. Putting GDM last does *not* solve the issue.
Comment by Otto Allmendinger (OttoA) - Thursday, 08 July 2010, 18:11 GMT
The issue is reported in gnomes bugtracker:
https://bugzilla.gnome.org/show_bug.cgi?id=511168

With an acceptable patch that is being used for openSUSE:
http://bugzilla-attachments.gnome.org/attachment.cgi?id=134497

I built gdm with this patch and it starts on vt7, even if I put gdm earlier in the DAEMONS array.

Patch for svn trunk:
http://pastebin.ca/1896872

Loading...