Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17464 - intel video drivers don't work with latest xorg

Attached to Project: Arch Linux
Opened by robin wood (dninja) - Friday, 11 December 2009, 15:13 GMT
Last edited by Jan de Groot (JGC) - Saturday, 12 December 2009, 11:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture i686
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I upgraded the following packages

libgl-7.6-2 intel-dri-7.6-2 xf86-input-evdev-2.3.1-1 xf86-input-keyboard-1.4.0-1 xf86-input-mouse-1.5.0-1 xf86-video-intel-2.9.1-1 xorg-server-1.7.3-1

and tried to start X but got the following at the end of the xorg log file

(II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
dlopen: /usr/lib/xorg/modules/drivers/intel_drv.so: undefined symbol: resVgaShared
(EE) Failed to load /usr/lib/xorg/modules/drivers/intel_drv.so
(II) UnloadModule: "intel"
(EE) Failed to load module "intel" (loader failed, 7)

I then rolled back to these versions:

xorg-server-1.6.3.901-1-i686.pkg.tar.gz xf86-input-evdev-2.2.5-1-i686.pkg.tar.gz xf86-input-keyboard-1.3.2-2-i686.pkg.tar.gz xf86-input-mouse-1.4.0-2-i686.pkg.tar.gz
libgl 7.5-2 intel-dri 7.5-2

And X is now working again.
This task depends upon

Closed by  Jan de Groot (JGC)
Saturday, 12 December 2009, 11:43 GMT
Reason for closing:  Works for me
Comment by Jan de Groot (JGC) - Friday, 11 December 2009, 19:37 GMT
The versions you reported are running fine here. Are you sure you're not running an unofficial version of one of the packages (xf86-video-intel compiled against old xorg-server), or do you still use the legacy driver somehow?
Comment by robin wood (dninja) - Friday, 11 December 2009, 20:09 GMT
No, all the packages came from the package system and were upgraded using pacman -Suy.
Comment by Jan de Groot (JGC) - Friday, 11 December 2009, 20:22 GMT
Can you attach Xorg.0.log of the not-working configuration?
Comment by robin wood (dninja) - Saturday, 12 December 2009, 11:03 GMT
I've just gone to upgrade again and it redownloaded xf86-video-intel-2.9.1-1 then installed everything and X is working ok.

Must have been a problem with the original download. Problem solved, you can close the ticket.

Loading...