Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17435 - [kernel26] 2.6.32 Thinkpad's trackpoint is not recognized

Attached to Project: Arch Linux
Opened by Ludovic Fauvet (etix) - Tuesday, 08 December 2009, 02:12 GMT
Last edited by Ionut Biru (wonder) - Sunday, 24 January 2010, 23:33 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
After upgrading to 2.6.32, my system does not recognize the trackpoint correctly.
In <= 2.6.31 the output of a lshal was "TPPS/2 IBM TrackPoint" now it is identified as "PS/2 Generic Mouse" which causes wrong behaviors with my hal policies.

Another issue (also reported by others) is that the speed and sensitivity cannot be set.

Additional info:
See http://bbs.archlinux.org/viewtopic.php?pid=668641


Steps to reproduce:

This task depends upon

Closed by  Ionut Biru (wonder)
Sunday, 24 January 2010, 23:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.6.32.5
Comment by Michał Barciś (zeroos) - Sunday, 10 January 2010, 08:30 GMT
This kernel is now in core, not in testing.
Comment by Ludovic Fauvet (etix) - Sunday, 10 January 2010, 12:46 GMT Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 20 January 2010, 04:15 GMT
Marked as solved on the bugzilla. Seems that is fixed on 2.6.32.3. Can you confirm this, then request closure? Thanks.
Comment by xduugu (xduugu) - Wednesday, 20 January 2010, 09:42 GMT Comment by xduugu (xduugu) - Saturday, 23 January 2010, 00:52 GMT Comment by Ludovic Fauvet (etix) - Sunday, 24 January 2010, 22:30 GMT
Problem solved in 2.6.32.5-1.
Thanks !

Loading...