Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17433 - [apache] doesn't start when /var/run/httpd is deleted (PATCH)

Attached to Project: Arch Linux
Opened by Johannes Dewender (JonnyJD) - Monday, 07 December 2009, 21:34 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 01 February 2010, 19:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Similar to http://bugs.archlinux.org/task/17129 the httpd daemon is not started when /var/run/httpd is missing.

It IS created during installation, but it does not stay i.e. when you have /var/run on tmpfs.
No Program should rely on anything in /var/run to survive a boot according to
http://tldp.org/LDP/Linux-Filesystem-Hierarchy/html/var.html

You can normally find the corresponding error in /var/log/http/error_log:
[Mon Dec 07 22:08:22 2009] [error] (2)No such file or directory: could not create /var/run/httpd/httpd.pid
[Mon Dec 07 22:08:22 2009] [error] httpd: could not log pid to file /var/run/httpd/httpd.pid

Additional info:
* package version(s)
apache 2.2.14-2


Steps to reproduce:
(/etc/rc.d/httpd stop)
rm -r /var/run/httpd
/etc/rc.d/httpd start
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 01 February 2010, 19:07 GMT
Reason for closing:  Implemented
Additional comments about closing:  on trunk
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 07 December 2009, 22:31 GMT
Some time ago, I started to make this posible, but marked as "won't implement"  FS#13225 

Apart of more FHS-complaint, this is better because pacman does not track directories.

This change was recently acepted in laptop-mode-tools:  FS#17240 

Loading...