Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17315 - [gdm] Changes to keyboard layouts are reverted after reboot

Attached to Project: Arch Linux
Opened by Michael Kogan (Photon) - Sunday, 29 November 2009, 09:43 GMT
Last edited by Jan de Groot (JGC) - Sunday, 28 March 2010, 12:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After an update about a month ago a new US keyboard layout appeared in the Gnome keyboard indicator. I'm using two layouts DE and RU and now this third one appeard. If I remove it from the layouts list it reappears after the next reboot. Details available here: http://bbs.archlinux.org/viewtopic.php?id=83090 The bug seems to have similarities with  FS#13188  but also some differences: In this case layout switching works perfectly, but removing layouts doesn't work.

P.S.: Sorry, I don't really know which package to blame of this bug since removing the US layout directly from the gconf-editor doesn't help either, so it seems not to be the keyboard indicators fault. Sorry for insufficient information.

Additional info:

Config files available in the forum link above.

Steps to reproduce:

The new layout appeared itself after some update.
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 28 March 2010, 12:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  Layout settings should be configured in X. If you remove a keyboard layout that happens to be the default layout in X, gdm selects that layout and passes it to gnome-settings-daemon as default layout, which adds it to your configuration again.
Passing that layout to gnome-settings-daemon was broken in older versions of gnome-settings-daemon and has been fixed in a recent version.
Comment by Michael Kogan (Photon) - Sunday, 29 November 2009, 09:57 GMT
I noticed that the switching keybindings were different in xorg.conf and 10-keymap.fdi and corrected the xorg.conf entry. Unfortunately it made the situation even worse: Now after a reboot only the US layout exists and the other ones (those that I actually use) are gone.
Comment by Jan de Groot (JGC) - Sunday, 29 November 2009, 13:40 GMT
gdm has been patched to read the keyboard layout from X after startup. If you set the keyboard layout from hal, then gdm should respect that setting.
Comment by Michael Kogan (Photon) - Sunday, 29 November 2009, 19:37 GMT
First of all, thanks for not closing this one immediately though it seems to be fixed. :) What exactly should be configured in which files and where is the problem in my current config files? Thanks!
Comment by Jan de Groot (JGC) - Sunday, 29 November 2009, 19:43 GMT
If you didn't disable input hotplugging, then the 10-keymap.fdi file should set the keyboard map. Note that you should copy this file to /etc/hal/fdi/policy to make it permanent, as every update to the hal package will overwrite your configuration files again.
Comment by Michael Kogan (Photon) - Sunday, 29 November 2009, 20:02 GMT
Hmm, hotplugging isn't explicitly disabled in the xorg.conf and the correct layouts are entered in 10-keymap.fdi (it's still the same as in the forum thread) but still the layout is set back to US after each reboot...
Comment by Michael Kogan (Photon) - Saturday, 05 December 2009, 09:49 GMT
Any progress on this one? Is there anything I can do for helping to track it down? It's quite unhandy to reset the keyboard settings on each login. :)

Thanks
Comment by Michael Kogan (Photon) - Wednesday, 23 December 2009, 18:13 GMT
I've solved the problem for me by bypassing GDM and logging in into Gnome directly. So it seems to be a problem of GDM.
Comment by Jan de Groot (JGC) - Saturday, 13 March 2010, 19:51 GMT
Is this fixed with gnome-settings-daemon 2.28.2? Previous versions expected tabs while gdm exports the keyboard variant with spaces or the other way around.

Loading...