Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17308 - [xmonad] /usr/share/applications/xmonad.desktop is not created by package

Attached to Project: Community Packages
Opened by Josh (segfault) - Saturday, 28 November 2009, 07:52 GMT
Last edited by Dan Griffiths (Ghost1227) - Saturday, 09 January 2010, 01:39 GMT
Task Type Bug Report
Category
Status Closed
Assigned To Vesa Kaihlavirta (vegai)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

For xmonad to be able to run inside GNOME and be used as its window manager, the file /usr/share/applications/xmonad.desktop must be created with these contents:

[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=Xmonad
Exec=xmonad
NoDisplay=true
X-GNOME-WMName=Xmonad
X-GNOME-Autostart-Phase=WindowManager
X-GNOME-Provides=windowmanager
X-GNOME-Autostart-Notify=false

Once the .desktop file is in place, GNOME's window manager can be switched to xmonad by running 'gconftool-2 -s /desktop/gnome/session/required_components/windowmanager xmonad --type string'. If the .desktop file is not in place, no window manager will start.

The current xmonad package doesn't create this file. I realize that the Archwiki page about bug reporting says to be weary of filing bugs concerning .desktop files, but I'm on the fence about this one. Figuring out why xmonad wouldn't start took hours of Googling that eventually led me here:xmonad@haskell.org/2009-06/msg00003.html"> http://osdir.com/ml/xmonad@haskell.org/2009-06/msg00003.html

I mentioned this in #xmonad on Freenode IRC, and then someone promptly added that information to an xmonad wiki article: http://www.haskell.org/haskellwiki/Xmonad/Using_xmonad_in_Gnome#Setting_up_Gnome_to_use_Xmonad

Although the information now appears in a more prominent place (the xmonad wiki,) simply having Arch's xmonad package create this file could potentially save someone hours of frustration.

Additional info:

Observed in the xmonad package, version 0.9-2.1.

Steps to reproduce:

Install the xmonad package.
This task depends upon

Closed by  Dan Griffiths (Ghost1227)
Saturday, 09 January 2010, 01:39 GMT
Reason for closing:  Not a bug
Additional comments about closing:  While this isn't a bug, the information is good to have access to. As such, I have added a line to the .install file that points users who wish to use xmonad in this way to the wiki article.
Comment by √ėyvind Heggstad (Mr.Elendig) - Tuesday, 15 December 2009, 11:50 GMT
This isn't really a bug imo. Normal policy in arch is to not provide .desktop files ourself(with exceptions), it's really a job for upstream.
Comment by Josh (segfault) - Tuesday, 15 December 2009, 20:03 GMT
I guess this is up for debate, then. :)

From the xmonad wiki article on xmonad+GNOME integration < http://www.haskell.org/haskellwiki/Xmonad/Using_xmonad_in_Gnome >:

"For xmonad to start automatically on login you need an applications/xmonad.desktop file on your system. If your distro doesn't provide it, create the following file:"

Seems to convey the exact opposite idea, that upstream isn't responsible for this, but distro packages are. Just throwing that out there.
Comment by Dan Griffiths (Ghost1227) - Monday, 04 January 2010, 00:01 GMT
I would suggest using an .install script that informs the user of the option to create this file.
Comment by Josh (segfault) - Monday, 04 January 2010, 05:03 GMT
Dan, that's an excellent idea. Ideally, the message would also give a short explanation of why the file might be needed.
Comment by Vesa Kaihlavirta (vegai) - Tuesday, 05 January 2010, 16:35 GMT
xmonad already installs a desktop file to /etc/X11/sessions/. Is this a wrong location?
Comment by Josh (segfault) - Tuesday, 05 January 2010, 16:40 GMT
This isn't a wrong location, but that file is only relevant if you want to run xmonad as a session. The problem I've described is related to running xmonad inside of GNOME as GNOME's window manager (instead of metacity.)

Loading...