Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17307 - [netcfg] Only first profile listed in rc.conf is started

Attached to Project: Arch Linux
Opened by Eric Belanger (Snowman) - Saturday, 28 November 2009, 06:18 GMT
Last edited by James Rayner (iphitus) - Saturday, 30 January 2010, 23:48 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To James Rayner (iphitus)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

These problems happens only when using netcfg-2.5.0rc1-1 in testing:

1) When starting the net-profiles daemon, I get a:
find: `/var/run/network//suspend/': No such file or directory

The daemon script should create that directory if it doesn't exist.

2) Only the first profile in NETWORKS is started. In my rc.conf, I have:
NETWORKS=(Ethernet-modem Ethernet-laptop !Wireless)

but only the Ethernet-modem profile is started. My Ethernet-laptop profile is being ignored.

$ cat /etc/network.d/Ethernet-modem
CONNECTION="ethernet"
DESCRIPTION="Ethernet profile for internet access (modem)"
INTERFACE=eth0
IP="dhcp"
DHCP_TIMEOUT=10

$ cat /etc/network.d/Ethernet-laptop
CONNECTION="ethernet"
DESCRIPTION="Ethernet profile for laptop access"
INTERFACE=eth1
IP="static"
IFOPTS="192.168.0.1 netmask 255.255.255.0 broadcast 192.168.0.255"

Let me know if you need more info.
This task depends upon

Closed by  James Rayner (iphitus)
Saturday, 30 January 2010, 23:48 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in 2.5.0
Comment by Philippe Miron (philefou) - Wednesday, 30 December 2009, 06:42 GMT
I tried to reproduce your second problem but every time, both profiles were starting..
Comment by Philippe Miron (philefou) - Wednesday, 30 December 2009, 06:45 GMT
Are you able to start both profiles after start up?
Comment by Eric Belanger (Snowman) - Saturday, 09 January 2010, 21:30 GMT
I tried with 2.5.0rc2-1 and same problem. It doesn't start after start up either.

The problem seem to be caused by the 'exit 0' in the case statement while looping over the content of the NETWORKS array. When I comment it out, both profiles are started even though I get a "> No profile started." message. I also doen't understand the:
echo "$network" > "$STATE_DIR/net-profiles"
line. It should use >> instaed of > not to clobber the file. Unless I'm mistaken, it looks like if it only support one profile.

Loading...