FS#17115 - [xorg] Mouse does not work properly after system upgrade

Attached to Project: Arch Linux
Opened by sftrytry (sftrytry) - Thursday, 12 November 2009, 21:40 GMT
Last edited by Jan de Groot (JGC) - Monday, 07 March 2011, 15:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


After the full system upgrades by -Syu on Nov11. My mouse did not work properly.
Here is the problem:
1. Press the left button and hold it
2. Press the right one and hold it
3. Release the left one while holding the right one.
4. Release the right one.
5. System thinks your left button is pressed forever.

After this magic procedure, mouse will act as if the left button is held forever unless you press and release the left button again. It is also true while you press right button first.

I guess the button release event is not caught while another button is held at the meantime. Thus the system never realizes the button has been released. I am not sure it has some thing to do with xorg, kernel26. I tried to downgrade this 2 packages/groups individually, but with no luck. I tested this on both 32bit and 64bit pc. Before "-Syu", they were all working, (xorg1.6.3/kernel26-2.6.30and31, ps2/usb mouse); after update(xorg1.7/kernel26-2.6.31), all of they were bugged.

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:
Do a full system upgrade after Nov 11 2009. It should be xorg-server-1.7+kernel26-2.6.31. And you can check it out with playing on the desktop(gnome/xfce I tried so far).
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 07 March 2011, 15:44 GMT
Reason for closing:  No response
Comment by sftrytry (sftrytry) - Friday, 13 November 2009, 00:04 GMT
It seems to have nth to do with kernel26 and xorg-server. I downgrade my system with my backup pkg. And then, I only upgrade kernel, xorg-server, and nvidia driver. Nth is wrong so far. There must be some other pkges to prevent the system getting mouse button release event.
Comment by sftrytry (sftrytry) - Friday, 13 November 2009, 00:06 GMT
Here is the list I updated:
kernel26-firmware 2.6.31-1
dbus-core-1.2.16-1 dbus-glib-0.82-2 udev-146-2
consolekit-0.4.1-1 hal-0.5.13-3 libfontenc-1.0.5-1
fontsproto-2.1.0-1 libxfont-1.4.1-1 libpciaccess-0.10.9-1
libxv-1.0.5-1 pixman-0.16.2-1 xcursor-themes-1.0.2-1
xf86-input-evdev-2.3.0-1 inputproto-2.0-1
nvidia 190.42-1
nvidia-utils 190.42-1
Comment by andrey demidov (demas) - Friday, 13 November 2009, 06:25 GMT Comment by sftrytry (sftrytry) - Friday, 13 November 2009, 22:44 GMT
No. My mouse works 99% percent well. It moves and clicks. Just the button release event is not caught when another button is being pressed. It is Ok for daily desktop use when you seldom press more than one button at the same time, but quit annoying when gaming.

BTW, nobady has the same experience?
Comment by sftrytry (sftrytry) - Friday, 18 December 2009, 23:49 GMT
I think it can be cloesd. After 1 whole day searching, I found it's a bug of gnome-settings-daemon >= 2.28. I rolled it back to 2.26 and libgnomekbd, everything worked fine. However, I could not change keyboard settings after that.

BTW, xfce4 has the same problem.
Comment by sftrytry (sftrytry) - Sunday, 20 December 2009, 08:54 GMT
I checked my laptop, which works fine with gnome-settings-daemon >= 2.28 and kernel26-2.6.29. Because I have an ATI card on the laptop, I can only stay with kernel26-2.6.29.

Maybe kernel26-2.6.3x + gnome-settings-daemon-2.28 cause the problem.
Comment by Jan de Groot (JGC) - Saturday, 26 December 2009, 18:33 GMT
Is this still an issue? This looks almost the same as the keyboard repeat problem that we fixed a short while ago by removing a patch.
Comment by sftrytry (sftrytry) - Sunday, 10 January 2010, 23:41 GMT
I think so. Both gnome 2.28 and the latest xfce4 till Jan 11 2010 have the same problem. I put gnome-settings-daemon in the ignore list. Gnome works fine so far but xfce4 does not. KDE dose not have the problem.
Comment by PyroPeter (pyropeter) - Saturday, 01 May 2010, 17:18 GMT
Maybe this issue should be renamed to reflect its relationship with gnome-settings-daemon.
Comment by Thomas Dziedzic (tomd123) - Monday, 28 June 2010, 18:15 GMT