Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17095 - [xorg-xdm] 1.1.9 segfaults

Attached to Project: Arch Linux
Opened by Sergej Pupykin (sergej) - Wednesday, 11 November 2009, 10:47 GMT
Last edited by Jan de Groot (JGC) - Monday, 17 May 2010, 17:33 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

xorg-xdm 1.1.9-2 segfaults in libc, please downgrade to 1.1.8.

Nov 11 02:49:04 home kernel: xdm[3111]: segfault at 7f904b656d10 ip 00007f904c573a01 sp 00007fff0c124178 error 4 in libc-2.10.1.so[7f904c4fa000+14a000]

I can confirm it for both i686 and x86_64.

More info: http://bugs.gentoo.org/286923
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 17 May 2010, 17:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with 1.1.10.
Comment by Vitaliy Berdinskikh (UR6LAD) - Friday, 13 November 2009, 20:23 GMT
The same bug.

Message
--------
xdm[1775]: segfault at b7836899 ip b75bb7ab sp bff0310c error 4 in libc-2.11.so[b7548000+140000]

Comment by Johannes Dewender (JonnyJD) - Friday, 13 November 2009, 22:10 GMT
What would be more interesting than to link to other distributions is linking to upstream bug reports ;-)

segfault after closing the window manager:
https://bugs.freedesktop.org/show_bug.cgi?id=24589

some similar segfault in 1.1.9:
https://bugs.freedesktop.org/show_bug.cgi?id=24588

Note:
There is an issue that xdm can't respawn with XDMCP enabled, after the segfault
https://bugs.freedesktop.org/show_bug.cgi?id=25045
and you might have this error message in xdm.log (if it doesn't respawn and create a new log) because of these segfaults:
xdm error (pid 14069): Unknown session exit code 2816 from process 14074
Comment by rob (deadbeefcafe) - Tuesday, 17 November 2009, 12:21 GMT
For me, I was able to workaround by reversing the fix for  FS#17042 , i.e.

rm -rf /var/lib/xdm

Of course, this brought back the "insecure session" message. Interestingly, logging in as root also evaded the segfault.
Comment by Jürgen Hagemann (cappucco) - Monday, 18 January 2010, 15:08 GMT
There is a fix (patch) on freedesktop org for this bug: http://bugs.freedesktop.org/show_bug.cgi?id=24589

Could you please bring it into arch?
THX
Comment by Jörg Kriegel (sokoban65) - Saturday, 30 January 2010, 17:40 GMT
I would also like to have this patch from http://bugs.freedesktop.org/show_bug.cgi?id=24589 included. It's also in the upstream git repository at:

http://cgit.freedesktop.org/xorg/app/xdm/commit/?id=ecf015a4e78b96af913c1620d542c8e356f2a3d0

This fixes the segfaults for me.
Comment by nik (sloopy) - Friday, 05 March 2010, 21:26 GMT
I'm still getting this error with xorg-xdm 1.1.9-2 and glibc 2.11.1-1:

Mar 5 00:33:51 bigchan kernel: xdm[14415]: segfault at b7719899 ip b74aed7b sp bfe5290c error 4 in libc-2.11.1.so[b743b000+141000]
Comment by Jörg Kriegel (sokoban65) - Tuesday, 09 March 2010, 21:49 GMT
@nik: xorg-xdm 1.1.9-2 was the old version. The fixed one is 1.1.9-3. Can you please double check which version of xorg-xdm caused the segfault. You can lookup version and install date with: pacman -Qi xorg-xdm

Curiously after examining my log files I found out that I had one single segfault myself with version 1.1.9-3:

Mar 5 13:53:50 imac kernel: xdm[3601]: segfault at 7ff000000001 ip 00007ff091e6ecae sp 00007fffeda856f0 error 4 in libc-2.11.1.so[7ff091e29000+14d000]

This was on X-Session logout after upgrading the readline and shadow packages in an X-Session. But I am not able to replicate it. Could this have been triggered by the shadow package update?
Comment by Jörg Kriegel (sokoban65) - Tuesday, 09 March 2010, 22:32 GMT
@nik: xorg-xdm 1.1.9-2 was the old version. The fixed one is 1.1.9-3. Can you please double check which version of xorg-xdm caused the segfault. You can lookup version and install date with: pacman -Qi xorg-xdm

Curiously after examining my log files I found out that I had one single segfault myself with version 1.1.9-3:

Mar 5 13:53:50 imac kernel: xdm[3601]: segfault at 7ff000000001 ip 00007ff091e6ecae sp 00007fffeda856f0 error 4 in libc-2.11.1.so[7ff091e29000+14d000]

This was on X-Session logout after upgrading the readline and shadow packages in an X-Session. But I am not able to replicate it. Could this have been triggered by the shadow package update?
Comment by Jörg Kriegel (sokoban65) - Tuesday, 09 March 2010, 22:33 GMT
Sorry for the repeted comment.
Comment by Jan de Groot (JGC) - Sunday, 09 May 2010, 18:34 GMT
Is this fixed with the update to 1.1.10?
Comment by Sergej Pupykin (sergej) - Monday, 17 May 2010, 15:55 GMT
At least it works for me now.

Loading...