Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#17037 - [xorg-server] 1.7.1.901 & KDE: slow graphics

Attached to Project: Arch Linux
Opened by Dmitry (rmammoth) - Saturday, 07 November 2009, 00:24 GMT
Last edited by Jan de Groot (JGC) - Sunday, 08 November 2009, 16:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 24
Private No

Details

Description: after last update to xorg server 1.7.1.901 kde menus and other stuffs has too long reaction time to user input. For example, kde main menu (kickoff) opened for 2-3 seconds instead approx 0.5 with previous xorg server revision. The same is for pluggable devices widget, etc. Downgrade to xorg server 1.7.1 restores responsibility.


Additional info:
* package version(s)

nvidia 190.42
kdebase-lib 4.3.3 (composite enabled, GL-accelerated rendering, count of effects activated)

* config and/or log files etc.
GeForce 9800GT/AMD Phenom II 810 x4/4Gb RAM/GIGABYTE MA790X-DS4

Steps to reproduce:
just #pacman -Suy and restart kde
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 08 November 2009, 16:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 1.7.1.901-2: removed fedora patch.
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 07 November 2009, 00:43 GMT
  • Field changed: Summary (Xorg server 1.7.1.901 & KDE: slow graphics → [xorg-server] 1.7.1.901 & KDE: slow graphics)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Architecture (x86_64 → All)
  • Field changed: Severity (Low → Medium)
  • Task assigned to Jan de Groot (JGC)
Confirmed on i686, KDE works very slow. (nvidia 7300GT)
Comment by Andrea Scarpino (BaSh) - Saturday, 07 November 2009, 01:45 GMT
no problem here with Intel
Comment by Bojan (gabriel9) - Saturday, 07 November 2009, 02:02 GMT
The problem is also on my computer, reaction on click is slow. Downgrading xorg-server solves problem.
Arch 64
Geforce 6150
Comment by Laszlo Papp (djszapi) - Saturday, 07 November 2009, 04:12 GMT
Intel, x86_64, no problem here.
Comment by ozar (ozar) - Saturday, 07 November 2009, 04:35 GMT
Confirming issue, as same happened on my KDE 4.3.3 box with the install of xorg-server 1.7.1.901. No other packages were updated and all actions in KDE are delayed by about 15 to 20 seconds. Reinstalling the previous version of xorg-server fixes these issues.
Comment by Pierre Schmitz (Pierre) - Saturday, 07 November 2009, 04:39 GMT
confirmed on a Geforce 7800GT. Whatever was changed in xorg-server 1.7.1.901 reduces performance significantly.
Comment by Pierre Schmitz (Pierre) - Saturday, 07 November 2009, 04:50 GMT
Removing the xserver-1.7.1-window-pictures.patch improves the situation a lot. So I'd vote for removing this patch for now.
Comment by Benjamin Robin (benjarobin) - Saturday, 07 November 2009, 05:21 GMT
Confirmed on a Geforce 8600mGT, i686, with KDE, everything up to date, when I try to log or when I open the menu of KDE (The K icon on the bottom right)
Rollback to 1.7.1-1 solve the problem, I have notice that on my Xorg.0.log

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3b) [0x809cbcb]
1: /usr/bin/X (mieqEnqueue+0x1ab) [0x80ec9cb]
2: /usr/bin/X (xf86PostMotionEventP+0xcc) [0x80a7c1c]
3: /usr/lib/xorg/modules/input/evdev_drv.so (0xa59df000+0x45d1) [0xa59e35d1]
4: /usr/lib/xorg/modules/input/evdev_drv.so (0xa59df000+0x48c6) [0xa59e38c6]
5: /usr/bin/X (0x8048000+0x66e2f) [0x80aee2f]
6: /usr/bin/X (0x8048000+0x10c9f4) [0x81549f4]
7: (vdso) (__kernel_sigreturn+0x0) [0xb7802400]
Comment by Vadim Naboikin (clearwater67) - Saturday, 07 November 2009, 08:09 GMT
Confirmed on a Geforce 9400 GT with KDE.

But before I upgraded to 1.7.1.901, I'd compiled 1.7.1 with xserver-1.7.1-window-pictures.patch (because of this - http://bugs.archlinux.org/task/16952) and didn't have any problem with the reaction speed.
Comment by Panos Filip (Flamelab) - Saturday, 07 November 2009, 08:55 GMT
Huge problem with lag here.

GTS250, with 190.42, with latest xorg-server.

Without the new fedora patch, it works OK.

WITH the fedora patch, huge lag on KDE4. It should be removed.
Comment by (N/A) (wantilles) - Saturday, 07 November 2009, 11:30 GMT
The same happens here.

x86_64, nVidia 9800GT, KDE4, nVidia 190.42.

I rebuilt the xorg-server package from abs, without the new fedora patch.

Behavior returns to normal.
Comment by Vincent Gibault (VGib) - Saturday, 07 November 2009, 12:21 GMT
Same problem for me, no errors in Xorg.conf or wrong informations.

Config: GeForce 9800GTX+
Nvidia driver: 190.42-1

Dowgrading the package to 1.7.1-1 solve the problem
Comment by nico (Nixxx) - Saturday, 07 November 2009, 14:50 GMT
Same here: When I want to open "Kick-off menu" it takes over 1 second form click to open. Same situation concerns "device info" icon which is also placed on toolbar.
Comment by Daniel Riedemann (darie) - Saturday, 07 November 2009, 15:10 GMT
> Comment by Vadim Naboikin (clearwater67)
> But before I upgraded to 1.7.1.901, I'd compiled 1.7.1 with xserver-1.7.1-window-pictures.patch
> and didn't have any problem with the reaction speed

I tried that and this is not true for me. The xserver is slow with the patch no matter what version I use.
So just to clarify this, the newest xserver (1.7.1.901) without the patch doesn't lag anymore for me.
Comment by Daniel Riedemann (darie) - Saturday, 07 November 2009, 15:24 GMT
Just wanted to add: without the patch the xserver of course crashes again (with using apps like gimp) with nvidia cards under kde. Ref.: http://bugs.archlinux.org/task/16952 :(
Comment by Vadim Naboikin (clearwater67) - Saturday, 07 November 2009, 15:50 GMT
> Comment by Daniel Riedemann (darie) - Saturday, 07 November 2009, 17:10 GMT+2
>> Comment by Vadim Naboikin (clearwater67)
>> But before I upgraded to 1.7.1.901, I'd compiled 1.7.1 with xserver-1.7.1-window-pictures.patch
>> and didn't have any problem with the reaction speed
>
> I tried that and this is not true for me. The xserver is slow with the patch no matter what version I use.
> So just to clarify this, the newest xserver (1.7.1.901) without the patch doesn't lag anymore for me.

I can send you my package (1.7.1 with xserver-1.7.1-window-pictures.patch, it is 4MB) and you can try it.
As for me it is works perfect (including gimp)
Comment by (N/A) (wantilles) - Saturday, 07 November 2009, 15:53 GMT
gimp works perfectly here with KDE, and WITHOUT the Fedora patch.
Comment by Panos Filip (Flamelab) - Saturday, 07 November 2009, 15:57 GMT
wantilles, try to open multiple images, and there will be a crash.
Comment by thibault (inflames) - Saturday, 07 November 2009, 18:21 GMT
Same problem in worse here on two different laptop... The system is so slow that it's not possible to use it (KDE 4.3.3)!!
I had to go back to xserver-1.7.1 to get it working.
Btw I know that Arch is a on the edge rolling release but a RC1 of xserver in stable is a realy bad idea!
Comment by Jan de Groot (JGC) - Saturday, 07 November 2009, 18:31 GMT
It's not the RC1 release that makes the problems, it's the patch that is supposed to fix the segfaults that causes the slowdowns. At this moment we have a choice: segfaults in GTK apps for nvidia users, or slow KDE when desktop effects are enabled.
Comment by Christian (zico) - Saturday, 07 November 2009, 18:37 GMT
May I please add a small comment?
I am one who can reproduce BOTH problems:
- With the patch I get Slowdowns in KDE
- Without the patch, GIMP crashes as soon as I open 4 images (around 2000x2000 px) and other random events

BUT - if I apply only the first part of the Patch - which is:
- pPixmap = (*pScreen->CreatePixmap) (pScreen, width, height, pDraw->depth, 0);
+ pPixmap = fbCreatePixmap (pScreen, width, height, pDraw->depth, 0);

Everything works completely fine here. No KDE Slowdowns and NO GIMP crashes

I do not have much experience with the code of Xorg, but I hope this helps someone. For me I use this solution since we struggled with the GTK crashes and it worked fine for me since then.
Comment by Jan de Groot (JGC) - Saturday, 07 November 2009, 19:00 GMT
Which is what version 3 of the patch did, resulting in Segmentation faults in the radeon drivers with dualhead configuration.
Comment by Gerardo Exequiel Pozzi (djgera) - Saturday, 07 November 2009, 19:57 GMT
@Panos: Please define "multiple files", I just opened 30 jpeg files of 3264x2448 (~2MB each) with gimp and no issues here (xorg-server-1.7.1-1 with custom 2.6.30.9 kernel -> nvidia 190.42 build by myself)
Comment by (N/A) (wantilles) - Saturday, 07 November 2009, 22:34 GMT
I have a large number of PNG files, 32-bit color, of 1280x960 resolution.

How many of them, to be opened simultaneously in gimp, would you consider a successfull test?

40? 50? 60?
Comment by Christian (zico) - Saturday, 07 November 2009, 22:36 GMT
For me, it only takes 4 simultaneous openings of JPG files (~2000x2000px) to get X to crash with xorg-server-1.7.1-1.
However that is ONLY in KDE and ONLY with nvidia binary driver and ONLY with KDE Desktop effects on.
Comment by (N/A) (wantilles) - Saturday, 07 November 2009, 22:42 GMT
I also have KDE, I also have nVidia's driver, I also have KDE desktop effects on.

I just opened 60 of the above-mentioned files, and the system didn't even break a sweat.

You want me to up it to 150 images, to prove my point?

Perhaps your xorg.conf and/or your nvidia-settings options are incorrect/unsuitable.
Comment by Christian (zico) - Saturday, 07 November 2009, 22:55 GMT
I do not even say you have not proven your point. I open 4 files and - BAM. You can open 150 files - so there is no bug, okay.
Even tho it might take a little more than just opening files to get a crash. I saw forum entries of complete different programs crashing X as well. Maybe this is also related to the reosolution, maybe it's related to one single special Desktop effect, maybe it's related to the Graphics card RAM, maybe it's related to the System RAM, maybe it's related to SWAP... shall I go on to prove *my* point?

So I attached my xorg.conf and .nvidia-settings-rc. I am MORE than happy if you can give me a hint on how to get GIMP working again without the Fedora patch.
Comment by David Nadlinger (klickverbot) - Saturday, 07 November 2009, 23:50 GMT
I am also experiencing this bug on an nVidia 8600M GT (190.42), Qt 4.6, KDE trunk: All kinds of »Plasma windows« like KRunner, context menus of systray icons, etc. freeze the whole desktop for several seconds (you cannot even Ctrl+Alt+<n> to a text console). My xorg.conf is pretty minimal, it only sets up »nvidia« instead of »nv«.
Comment by ozar (ozar) - Saturday, 07 November 2009, 23:59 GMT
Noticed that lots of people are saying that the new xorg-server is a problem for those with desktop effects turned on, but just for the sake of clarity, the new xorg-server 1.7.1.901 locks up my KDE box even though desktop effects are "turned off", so it's apparently a problem, either way.
Comment by Alexander (hokum_rus) - Sunday, 08 November 2009, 00:57 GMT
Confirm this on kdemod 4.3.3
nvidia 190.42-1
and xorg-server 1.7.1.901-1
Notable slowdown on most kde operation, system totally unresponsive for few seconds.
Comment by Andrew Mellor (quantumphaze) - Sunday, 08 November 2009, 03:34 GMT
http://bugs.archlinux.org/task/17037#comment52785

I can confirm that this works.
When I perform the action that crashes X in Gimp (drag one of the ruler bars onto the image, seen in the video at task/16952) it doesn't crash X and KDE is as snappy as always.
Comment by Panos Filip (Flamelab) - Sunday, 08 November 2009, 04:58 GMT
@djgera: I just selected 10 images in the window where you choose which images you want to open, I had some really huge wallpapers (2xxx x 2xxx ) PNGs, gimp started to paint some of them on the screen and after a while, baaaam, black screen, and here we are at KDM.
Comment by André Fettouhi (A.Fettouhi) - Sunday, 08 November 2009, 08:03 GMT
Same problem here with kdemod, latest nvidia and xorg. System becomes unresponsive when using qt apps but is fine with gtk apps though xorg crashes randomly when opening thunderbird.
Comment by (N/A) (wantilles) - Sunday, 08 November 2009, 09:19 GMT
To be honest, I have built myself (from abs) the newest gimp 2.6.7, and I am using that (also built on top of the new babl & gegl that I also built myself -> all these three packages in extra are flagged out of date). But I do not think this makes any difference.

To be honest, the only gtk2 app that crashes a lot recently here, is filezilla.
Comment by (N/A) (wantilles) - Sunday, 08 November 2009, 09:22 GMT
@ zico

Here is my xorg.conf.
Comment by Lisa Denia (eiffel56) - Sunday, 08 November 2009, 11:00 GMT
Confirming this on NVidia 9600M GT, latest KDE from Arch, up-to-date Arch Linux.
Comment by Andrew Mellor (quantumphaze) - Sunday, 08 November 2009, 11:28 GMT
I'm pretty sure this is effects Nvidia graphic cards. No one else has confirmed otherwise.
The title should be changed to reflect this.

I have a GeForce 9300M GS

Has anyone else tried zico's partial patch thing yet? It needs to be better tested, not only on Nvidia cards, but others to test for regressions.
Comment by Panos Filip (Flamelab) - Sunday, 08 November 2009, 12:26 GMT
The partial patch works OK.
Comment by (N/A) (wantilles) - Sunday, 08 November 2009, 12:28 GMT
No patch works very well for me.

Also zico's patch works very well for me, as well.
Comment by mardi (eeg) - Sunday, 08 November 2009, 13:52 GMT
Hit the same problems... slow taskbar, krunner, anything kde-plasma related
- Nvidia 8800GT (190.42-1)
- x86_64
- kde 4.3.3


Downgrading from xorg-server-1.7.1-901-1 to xorg-server-1.7.1-1 fixed the problem.
Comment by Pat (whaevr) - Sunday, 08 November 2009, 16:01 GMT
Same problem here
x86_64
nvidia binary driver (9800GT)
kdemod 4.3.3

Rebuilding xorg-server without the "xserver-1.7.1-window-pictures.patch" fixed the problem

Loading...